
CVE catalog
CVE-2026-52845
Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the
- Severity
- High · CVSS 8.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.45% · Oct 25, 2026
Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | caddy | sid | 2.11.4-1 | fixed |
| Debian | caddy | forky | 2.11.4-1 | fixed |
| Debian | caddy | trixie | 2.6.2-12+deb13u1 | fixed |
| Debian | caddy | trixie-security | 2.6.2-12+deb13u1 | fixed |
| Debian | caddy | bookworm | 2.6.2-5 | vulnerable |
| Debian | caddy | bookworm-security | 2.6.2-5+deb12u1 | fixed |
| Cpe | caddy | Not reported | Not reported | vulnerable |
| Cpe | caddy | Not reported | 2.11.4 | fixed |
| Go | github.com/caddyserver/caddy/v2 | Not reported | 2.11.4 | fixed |
| Cpe | caddy | Not reported | 2.11.4 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | caddy | source | sid | 2.11.4-1 | not yet assigned | Not reported | [1140773] |
| Debian | caddy | source | forky | 2.11.4-1 | not yet assigned | Not reported | [1140773] |
| Debian | caddy | source | trixie | 2.6.2-12+deb13u1 | not yet assigned | Not reported | [1140773] |
| Debian | caddy | source | bookworm | 2.6.2-5+deb12u1 | not yet assigned | Not reported | [1140773] |
| Cpe | caddy | cpe | Not reported | 2.11.4 | Not reported | Not reported | Not reported |
| Go | github.com/caddyserver/caddy/v2 | Go | Not reported | 2.11.4 | Not reported | Not reported | Not reported |
| Cpe | caddy | cpe | Not reported | 2.11.4 | Not reported | NVD-CVE-2026-52845 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [caddy]Affected
Details (2)
2.6.2-5· amd64 · bookwormAffected · Fixed:
2.6.2-5+deb12u1nvd · caddy · debian · bookworm; nvd · caddy · debian · 12
2.6.2-5· arm64 · bookwormAffected · Fixed:
2.6.2-5+deb12u1nvd · caddy · debian · bookworm; nvd · caddy · debian · 12
[Debian 13 (Trixie)]
- [caddy]Affected
Details (5)
2.6.2-12+b3· amd64 · trixieAffected · Fixed:
2.6.2-12+deb13u1nvd · caddy · debian · 13
2.6.2-12+b3· arm64 · trixieAffected · Fixed:
2.6.2-12+deb13u1nvd · caddy · debian · 13
2.11.2-1~bpo13+1· amd64 · trixie-backportsFixed · Fixed:
2.6.2-12+deb13u1nvd · caddy · debian · 13
2.6.2-12+deb13u1· amd64 · trixie-securityFixed · Fixed:
2.6.2-12+deb13u1nvd · caddy · debian · 13
2.6.2-12+deb13u1· arm64 · trixie-securityFixed · Fixed:
2.6.2-12+deb13u1nvd · caddy · debian · 13
Observed:
References
- [https://access.redhat.com/security/cve/CVE-2026-52845]
- [https://bugzilla.redhat.com/show_bug.cgi?id=2491907]
- [https://github.com/caddyserver/caddy/security/advisories/GHSA-f59h-q822-g45g]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-52845]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-52845]
- [https://pkg.go.dev/vuln/GO-2026-5346]
- [https://security-tracker.debian.org/tracker/CVE-2026-52845]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-52845.json]
[Debian Security Tracker] · [FIRST EPSS] · [Go Vulnerability Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]