
CVE catalog
CVE-2026-54338
JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. Prior to 5.5.0, invalid input to form-based login authenticators can place an unbounded attacker-controlle
- Severity
- Medium · CVSS 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.44% · Oct 25, 2026
JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. Prior to 5.5.0, invalid input to form-based login authenticators can place an unbounded attacker-controlled username in failed-login logs, allowing an unauthenticated attacker to consume logging and storage resources. This issue is fixed in version 5.5.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | jupyterhub | sid | 5.2.1+ds1-5 | vulnerable |
| Debian | jupyterhub | forky | 5.2.1+ds1-5 | vulnerable |
| Debian | jupyterhub | trixie | 5.2.1+ds1-4 | vulnerable |
| Debian | jupyterhub | bookworm | 3.0.0+ds1-1 | vulnerable |
| Pip | jupyterhub | Not reported | 5.5.0 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | jupyterhub | source | sid | (unfixed) | not yet assigned | Not reported | [1143967] |
| Debian | jupyterhub | source | forky | (unfixed) | not yet assigned | Not reported | [1143967] |
| Debian | jupyterhub | source | trixie | (unfixed) | not yet assigned | Not reported | [1143967] |
| Debian | jupyterhub | source | bookworm | (unfixed) | not yet assigned | Not reported | [1143967] |
| Pip | jupyterhub | pip | Not reported | 5.5.0 | Not reported | GHSA-P43P-WHWX-Q52H | Not reported |
Notes
[trixie] jupyterhub: Minor issue [bookworm] jupyterhub: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [jupyterhub]Affected
Details (2)
3.0.0+ds1-1· all · bookwormAffected
nvd · jupyterhub · debian · bookworm; nvd · jupyterhub · debian · 12
3.0.0+ds1-1· all · bookwormAffected
nvd · jupyterhub · debian · bookworm; nvd · jupyterhub · debian · 12
[Debian 13 (Trixie)]
- [jupyterhub]Affected
Details (2)
5.2.1+ds1-4· all · trixieAffected
nvd · jupyterhub · debian · 13
5.2.1+ds1-4· all · trixieAffected
nvd · jupyterhub · debian · 13
Observed:
References
- [https://github.com/advisories/GHSA-p43p-whwx-q52h]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-54338]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-54338]
- [https://security-tracker.debian.org/tracker/CVE-2026-54338]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]