
CVE catalog
CVE-2026-56820
Netty is a network application framework for development of protocol servers and clients. In versions 4.2.0.Final through 4.2.15.Final and prior to 4.1.135.Final, `OcspClient` does not validate that t
- Severity
- High · CVSS 7.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.31% · Oct 25, 2026
Netty is a network application framework for development of protocol servers and clients. In versions 4.2.0.Final through 4.2.15.Final and prior to 4.1.135.Final, `OcspClient` does not validate that the `CertificateID` in an OCSP response matches the requested `CertificateID`, which can lead to replay attack. `OcspClient.validateResponse` accepts a legitimately signed `GOOD` status response for an unrelated certificate issued by the same CA, allowing bypass of revocation checks for another certificate. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | netty | sid | 1:4.1.48-16 | vulnerable |
| Debian | netty | forky | 1:4.1.48-16 | vulnerable |
| Debian | netty | trixie | 1:4.1.48-10+deb13u1 | vulnerable |
| Debian | netty | trixie-security | 1:4.1.48-10+deb13u1 | vulnerable |
| Debian | netty | bookworm | 1:4.1.48-7+deb12u2 | vulnerable |
| Debian | netty | bookworm-security | 1:4.1.48-7+deb12u2 | vulnerable |
| Maven | io.netty:netty-handler-ssl-ocsp | Not reported | 4.2.16.Final | fixed |
| Maven | io.netty:netty-handler-ssl-ocsp | Not reported | 4.1.136.Final | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | netty | source | sid | (unfixed) | not yet assigned | Not reported | [1142680] |
| Debian | netty | source | forky | (unfixed) | not yet assigned | Not reported | [1142680] |
| Debian | netty | source | trixie | (unfixed) | not yet assigned | Not reported | [1142680] |
| Debian | netty | source | bookworm | (unfixed) | not yet assigned | Not reported | [1142680] |
| Maven | io.netty:netty-handler-ssl-ocsp | maven | Not reported | 4.2.16.Final | Not reported | Not reported | Not reported |
| Maven | io.netty:netty-handler-ssl-ocsp | maven | Not reported | 4.1.136.Final | Not reported | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libnetty-java]Affected
Source package: [netty]
Details (4)
1:4.1.48-7+deb12u2· all · bookwormAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookwormAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
[Debian 13 (Trixie)]
- [libnetty-java]Affected
Source package: [netty]
Details (4)
1:4.1.48-10+deb13u1· all · trixieAffected
nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixieAffected
nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityAffected
nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityAffected
nvd · netty · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11394-1.json]
- [https://github.com/advisories/GHSA-272m-gcwp-mpwg]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-56820]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-56820]
- [https://security-tracker.debian.org/tracker/CVE-2026-56820]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-56820.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2356.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]