
CVE catalog
CVE-2026-56822
netty: CVE-2026-56822
- Severity
- High · CVSS 7.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.17% · Oct 27, 2026
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the OcspServerCertificateValidator forwards the SslHandshakeCompletionEvent before the asynchronous OCSP validation completes. This allows the client's downstream handlers to send sensitive application data (e.g., HTTP requests) to a revoked server before the channel is closed by the OCSP check. n io.netty.handler.ssl.ocsp.OcspServerCertificateValidator#userEventTriggered, when an SslHandshakeCompletionEvent is received, the validator immediately calls ctx.fireUserEventTriggered(evt). It then initiates an asynchronous OCSP query using OcspClient.query. Because the handshake completion event is forwarded immediately, downstream handlers in the client's pipeline are notified that the TLS handshake is successful. They may then begin reading and processing incoming application data or sending outgoing data. If the OCSP response later indicates the server's certificate is REVOKED, the validator closes the channel, but by this time, the client may have already leaked sensitive data to a revoked server or processed malicious responses from it. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | netty | sid | 1:4.1.48-16 | vulnerable |
| Debian | netty | forky | 1:4.1.48-16 | vulnerable |
| Debian | netty | trixie | 1:4.1.48-10+deb13u1 | vulnerable |
| Debian | netty | trixie-security | 1:4.1.48-10+deb13u1 | vulnerable |
| Debian | netty | bookworm | 1:4.1.48-7+deb12u2 | vulnerable |
| Debian | netty | bookworm-security | 1:4.1.48-7+deb12u2 | vulnerable |
| Maven | io.netty:netty-handler-ssl-ocsp | Not reported | 4.2.16.Final | fixed |
| Maven | io.netty:netty-handler-ssl-ocsp | Not reported | 4.1.136.Final | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | netty | source | sid | (unfixed) | not yet assigned | Not reported | [1143052] |
| Debian | netty | source | forky | (unfixed) | not yet assigned | Not reported | [1143052] |
| Debian | netty | source | trixie | (unfixed) | not yet assigned | Not reported | [1143052] |
| Debian | netty | source | bookworm | (unfixed) | not yet assigned | Not reported | [1143052] |
| Maven | io.netty:netty-handler-ssl-ocsp | maven | Not reported | 4.2.16.Final | Not reported | Not reported | Not reported |
| Maven | io.netty:netty-handler-ssl-ocsp | maven | Not reported | 4.1.136.Final | Not reported | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libnetty-java]Affected
Source package: [netty]
Details (4)
1:4.1.48-7+deb12u2· all · bookwormAffected
dsa · netty · debian · bookworm; dsa · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookwormAffected
dsa · netty · debian · bookworm; dsa · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityAffected
dsa · netty · debian · bookworm; dsa · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityAffected
dsa · netty · debian · bookworm; dsa · netty · debian · 12
[Debian 13 (Trixie)]
- [libnetty-java]Affected
Source package: [netty]
Details (4)
1:4.1.48-10+deb13u1· all · trixieAffected
dsa · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixieAffected
dsa · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityAffected
dsa · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityAffected
dsa · netty · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11394-1.json]
- [https://github.com/advisories/GHSA-wc96-39fc-566f]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-56822]
- [https://security-tracker.debian.org/tracker/CVE-2026-56822]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-56822.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2356.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]