
CVE catalog
CVE-2026-57211
RabbitMQ is a messaging and streaming broker. Prior to 4.1.11 and 4.2.6 on Windows, the RabbitMQ management plugin static file handler rabbit_mgmt_wm_static can pass URL-encoded backslashes to erl_pri
- Severity
- Critical · CVSS 10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.63% · Oct 25, 2026
RabbitMQ is a messaging and streaming broker. Prior to 4.1.11 and 4.2.6 on Windows, the RabbitMQ management plugin static file handler rabbit_mgmt_wm_static can pass URL-encoded backslashes to erl_prim_loader:read_file_info before path validation when multiple management extension plugins are enabled, causing outbound DNS and SMB requests to attacker-controlled UNC paths. This issue is fixed in versions 4.1.11 and 4.2.6.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rabbitmq-server | sid | 4.3.6-1 | not affected |
| Debian | rabbitmq-server | forky | 4.3.6-1 | not affected |
| Debian | rabbitmq-server | trixie | 4.0.5-6+deb13u2 | not affected |
| Debian | rabbitmq-server | bookworm | 3.10.8-1.1+deb12u1 | not affected |
| Debian | rabbitmq-server | bookworm-security | 3.10.8-1.1+deb12u1 | not affected |
| Cpe | rabbitmq_server | Not reported | 4.2.6 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rabbitmq-server | source | sid | Not affected | unimportant | Not reported | Not reported |
| Debian | rabbitmq-server | source | forky | Not affected | unimportant | Not reported | Not reported |
| Debian | rabbitmq-server | source | trixie | Not affected | unimportant | Not reported | Not reported |
| Debian | rabbitmq-server | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Cpe | rabbitmq_server | cpe | Not reported | 4.2.6 | Not reported | NVD-CVE-2026-57211 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [rabbitmq-server]Not affected
Details (4)
3.10.8-1.1+deb12u1· all · bookwormNot affected
nvd · rabbitmq-server · debian · bookworm
3.10.8-1.1+deb12u1· all · bookwormNot affected
nvd · rabbitmq-server · debian · bookworm
3.10.8-1.1+deb12u1· all · bookworm-securityNot affected
nvd · rabbitmq-server · debian · bookworm
3.10.8-1.1+deb12u1· all · bookworm-securityNot affected
nvd · rabbitmq-server · debian · bookworm
Observed:
References
- [https://github.com/rabbitmq/rabbitmq-server/commit/39c3a8e9c71da0403d8dfc13f700e60c936e3682]
- [https://github.com/rabbitmq/rabbitmq-server/commit/6730797f6a34b4e8308cea60adf1243857e70204]
- [https://github.com/rabbitmq/rabbitmq-server/pull/15803]
- [https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6]
- [https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-7v84-m3g5-vxq6]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-57211]
- [https://security-tracker.debian.org/tracker/CVE-2026-57211]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-57211.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1994.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [Red Hat security advisories and VEX]