
CVE catalog
CVE-2026-58266
UBUNTU-
Anki is a program for creating and reviewing flashcards. Prior to 25.09.4, Anki's webview-based pages communicate with the Rust backend using an internal localhost API, and user scripts included via iframes in the editor can access this API despite protections intended to block reviewer and editor scripts. A malicious imported card package with an embedded iframe can use exposed API methods such as getImageForOcclusion to read arbitrary files accessible to the Anki process and exfiltrate them over the network. This issue is fixed in version 25.09.4.
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.22% · Oct 27, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "anki",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "16.04",
"versions": [
"2.0.32+dfsg-1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-58266"
},
{
"name": "anki",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "18.04",
"versions": [
"2.1.0+dfsg~a12-0.1",
"2.1.0+dfsg~b24-1",
"2.1.0+dfsg~b25-1",
"2.1.0+dfsg~b26-1",
"2.1.0+dfsg~b27-1",
"2.1.0+dfsg~b29-1",
"2.1.0+dfsg~b31-1",
"2.1.0+dfsg~b33-1",
"2.1.0+dfsg~b34-1",
"2.1.0+dfsg~b35-1",
"2.1.0+dfsg~b36-1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-58266"
},
{
"name": "anki",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "20.04",
"versions": [
"2.1.8+dfsg-1ubuntu1",
"2.1.15+dfsg-1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-58266"
},
{
"name": "anki",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "22.04",
"versions": [
"2.1.15+dfsg-3",
"2.1.15+dfsg-3ubuntu0.1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-58266"
},
{
"name": "anki",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "24.04",
"versions": [
"2.1.15+dfsg-3ubuntu1",
"2.1.15+dfsg-3ubuntu2",
"2.1.15+dfsg-3ubuntu3",
"2.1.15+dfsg-3ubuntu4",
"2.1.15+dfsg-3ubuntu4.1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-58266"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
Observed:
References
- [https://github.com/ankitects/anki/commit/b2b68d829e853da51b5de8aad6c13b53e90bc20d]
- [https://github.com/ankitects/anki/releases/tag/25.09.4]
- [https://github.com/ankitects/anki/security/advisories/GHSA-cw6h-ffmh-x6vh]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-58266]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-58266]
[FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]