
CVE catalog
CVE-2026-59153
UBUNTU-
Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.
- Severity
- Low · CVSS 2.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.26% · Oct 27, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "anki",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "16.04",
"versions": [
"2.0.32+dfsg-1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-59153"
},
{
"name": "anki",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "18.04",
"versions": [
"2.1.0+dfsg~a12-0.1",
"2.1.0+dfsg~b24-1",
"2.1.0+dfsg~b25-1",
"2.1.0+dfsg~b26-1",
"2.1.0+dfsg~b27-1",
"2.1.0+dfsg~b29-1",
"2.1.0+dfsg~b31-1",
"2.1.0+dfsg~b33-1",
"2.1.0+dfsg~b34-1",
"2.1.0+dfsg~b35-1",
"2.1.0+dfsg~b36-1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-59153"
},
{
"name": "anki",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "20.04",
"versions": [
"2.1.8+dfsg-1ubuntu1",
"2.1.15+dfsg-1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-59153"
},
{
"name": "anki",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "22.04",
"versions": [
"2.1.15+dfsg-3",
"2.1.15+dfsg-3ubuntu0.1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-59153"
},
{
"name": "anki",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "24.04",
"versions": [
"2.1.15+dfsg-3ubuntu1",
"2.1.15+dfsg-3ubuntu2",
"2.1.15+dfsg-3ubuntu3",
"2.1.15+dfsg-3ubuntu4",
"2.1.15+dfsg-3ubuntu4.1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-59153"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
Observed:
References
- [https://github.com/ankitects/anki/commit/858e5689d0e4fd24f74856c7e8f245412694a219]
- [https://github.com/ankitects/anki/releases/tag/25.09.3]
- [https://github.com/ankitects/anki/security/advisories/GHSA-869j-r97x-hx2g]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-59153]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-59153]
- [https://x.com/taviso/status/2051310678800253318]
[FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]