
CVE catalog
CVE-2026-59821
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.82.0-stable, LiteLLM's Custom Code Guardrails production create and update paths did not apply the same
- Severity
- High · CVSS 7.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.90% · Oct 25, 2026
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.82.0-stable, LiteLLM's Custom Code Guardrails production create and update paths did not apply the same sandboxing and validation used by the test endpoint, allowing a privileged user with access to create or update guardrails to submit custom Python code that executed in the LiteLLM proxy environment and could expose secrets available to the process. This issue is fixed in version 1.82.0-stable.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Pip | litellm | Not reported | 1.82.0 | fixed |
| PyPI | litellm | Not reported | 1.82.0 | fixed |
| PyPI | litellm | Not reported | 1.82.0 | fixed |
| Cpe | litellm | Not reported | Not reported | unknown |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Pip | litellm | pip | Not reported | 1.82.0 | Not reported | Not reported | Not reported |
| PyPI | litellm | PyPI | Not reported | 1.82.0 | Not reported | PYSEC-2026-3478 | Not reported |
| PyPI | litellm | PyPI | Not reported | 1.82.0 | Not reported | GHSA-72M8-9M7M-H278 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://github.com/BerriAI/litellm/commit/e50b4486d0f7aa0497185a1ebcdd2c91f1769eba]
- [https://github.com/BerriAI/litellm/releases/tag/v1.82.0-stable]
- [https://github.com/BerriAI/litellm/security/advisories/GHSA-72m8-9m7m-h278]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-59821]
- [https://osv.dev/vulnerability/GHSA-72m8-9m7m-h278]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-59821.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2263.json]
[CERT-Bund public advisories] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]