
CVE catalog
CVE-2026-59870
js-yaml is a JavaScript YAML parser and dumper. Prior to 3.15.1, 4.3.1, and 5.2.1, YAML11_SCHEMA support for the !!omap tag in src/tag/sequence/omap.ts uses omapTag.addItem() to perform a linear dupli
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.74% · Oct 25, 2026
js-yaml is a JavaScript YAML parser and dumper. Prior to 3.15.1, 4.3.1, and 5.2.1, YAML11_SCHEMA support for the !!omap tag in src/tag/sequence/omap.ts uses omapTag.addItem() to perform a linear duplicate-key scan on every insertion, causing O(n^2) CPU consumption when yaml.load() parses a crafted ordered-map document. In v3 and v4, !!omap is active and exploitable by default. v5 doesn't use !!omap by default, and the chances of activating it are very low.This issue is fixed in 3.15.1, 4.3.1, and 5.2.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-js-yaml | sid | 4.3.2+~4.0.9-1 | not affected |
| Debian | node-js-yaml | forky | 4.3.2+~4.0.9-1 | not affected |
| Debian | node-js-yaml | trixie | 4.1.0+dfsg+~4.0.5-7 | not affected |
| Debian | node-js-yaml | bookworm | 4.1.0+dfsg+~4.0.5-7 | not affected |
| Cpe | js-yaml | Not reported | 5.2.1 | fixed |
| Npm | js-yaml | Not reported | 5.2.1 | fixed |
| Cpe | js-yaml | Not reported | 5.2.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-js-yaml | source | sid | Not affected | unimportant | Not reported | Not reported |
| Debian | node-js-yaml | source | forky | Not affected | unimportant | Not reported | Not reported |
| Debian | node-js-yaml | source | trixie | Not affected | unimportant | Not reported | Not reported |
| Debian | node-js-yaml | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Cpe | js-yaml | cpe | Not reported | 5.2.1 | Not reported | Not reported | Not reported |
| Npm | js-yaml | npm | Not reported | 5.2.1 | Not reported | Not reported | Not reported |
| Cpe | js-yaml | cpe | Not reported | 5.2.1 | Not reported | NVD-CVE-2026-59870 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-js-yaml]Not affected
Details (2)
4.1.0+dfsg+~4.0.5-7· all · bookwormNot affected
nvd · node-js-yaml · debian · bookworm
4.1.0+dfsg+~4.0.5-7· all · bookwormNot affected
nvd · node-js-yaml · debian · bookworm
Observed:
References
- [https://github.com/advisories/GHSA-724g-mxrg-4qvm]
- [https://github.com/nodeca/js-yaml/commit/22a8071ef032117bc6249c330b240ac3aa2d3ded]
- [https://github.com/nodeca/js-yaml/commit/39f3211a2f01b3c6982710cf21434ab7060acefe]
- [https://github.com/nodeca/js-yaml/commit/c3cc4b0bb9ddb9af2dd9b61e0d56f5ce7983cd4a]
- [https://github.com/nodeca/js-yaml/releases/tag/3.15.1]
- [https://github.com/nodeca/js-yaml/releases/tag/4.3.1]
- [https://github.com/nodeca/js-yaml/releases/tag/5.2.1]
- [https://github.com/nodeca/js-yaml/security/advisories/GHSA-724g-mxrg-4qvm]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-59870]
- [https://security-tracker.debian.org/tracker/CVE-2026-59870]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-59870.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-3221.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [Red Hat security advisories and VEX]