
CVE catalog
CVE-2026-59878
Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All. A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.78% · Oct 25, 2026
Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All. A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections. This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | activemq | sid | 5.17.6+dfsg-2 | vulnerable |
| Debian | activemq | trixie | 5.17.6+dfsg-2 | vulnerable |
| Debian | activemq | bookworm | 5.17.2+dfsg-2+deb12u1 | vulnerable |
| Debian | activemq | bookworm-security | 5.17.2+dfsg-2+deb12u1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [activemq]Affected
Details (4)
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
- [libactivemq-java]Affected
Source package: [activemq]
Details (4)
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
[Debian 13 (Trixie)]
- [activemq]Affected
Details (2)
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
- [libactivemq-java]Affected
Source package: [activemq]
Details (2)
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-59878]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-59878]
- [https://security-tracker.debian.org/tracker/CVE-2026-59878]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2530.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]