
CVE catalog
CVE-2026-59882
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Prior to 2.12.3, Uri::assertValidHost() does not reject URI host components containing authority delimiters, embedded ports, or m
- Severity
- Medium · CVSS 4.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.32% · Oct 25, 2026
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Prior to 2.12.3, Uri::assertValidHost() does not reject URI host components containing authority delimiters, embedded ports, or malformed IPv6 brackets, allowing Uri::getHost() to disagree with the URI authority used for security or routing decisions. This issue is fixed in version 2.12.3.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | php-guzzlehttp-psr7 | sid | 2.13.1-1 | fixed |
| Debian | php-guzzlehttp-psr7 | forky | 2.13.1-1 | fixed |
| Debian | php-guzzlehttp-psr7 | trixie | 2.7.1-1+deb13u2 | vulnerable |
| Debian | php-guzzlehttp-psr7 | bookworm | 2.4.5-1+deb12u1 | vulnerable |
| Cpe | php-guzzlehttp-psr7 | Not reported | Not reported | vulnerable |
| Composer | guzzlehttp/psr7 | Not reported | 2.12.3 | fixed |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.1.0-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.2.0-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.2.1-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.2.2-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.2.2-1build1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.2.2-1ubuntu1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 20.04 | 1.4.2-0.1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 20.04 | 1.4.2-0.1+deb10u2build0.20.04.1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | pro | 1.7.0-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | pro | 1.8.3-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | pro | 1.8.3-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 24.04 | 2.6.0-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 24.04 | 2.6.1-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 24.04 | 2.6.2-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 25.10 | 2.7.0-3 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 25.10 | 2.7.1-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 26.04 | 2.7.1-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 26.04 | 2.8.0-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 26.04 | 2.8.0-2 | vulnerable |
| Cpe | psr-7 | Not reported | 2.12.3 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | php-guzzlehttp-psr7 | source | sid | 2.12.3-1 | not yet assigned | Not reported | Not reported |
| Debian | php-guzzlehttp-psr7 | source | forky | 2.12.3-1 | not yet assigned | Not reported | Not reported |
| Debian | php-guzzlehttp-psr7 | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | php-guzzlehttp-psr7 | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Composer | guzzlehttp/psr7 | composer | Not reported | 2.12.3 | Not reported | Not reported | Not reported |
| Cpe | psr-7 | cpe | Not reported | 2.12.3 | Not reported | NVD-CVE-2026-59882 | Not reported |
Notes
[trixie] php-guzzlehttp-psr7: Minor issue [bookworm] php-guzzlehttp-psr7: Minor issue; weak URI host validation, getHost() can disagree with the authority
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [php-guzzlehttp-psr7]Affected
Details (2)
2.4.5-1+deb12u1· all · bookwormAffected
nvd · php-guzzlehttp-psr7 · debian · bookworm; nvd · php-guzzlehttp-psr7 · debian · 12
2.4.5-1+deb12u1· all · bookwormAffected
nvd · php-guzzlehttp-psr7 · debian · bookworm; nvd · php-guzzlehttp-psr7 · debian · 12
[Debian 13 (Trixie)]
- [php-guzzlehttp-psr7]Affected
Details (2)
2.7.1-1+deb13u1· all · trixieAffected
nvd · php-guzzlehttp-psr7 · debian · 13
2.7.1-1+deb13u1· all · trixieAffected
nvd · php-guzzlehttp-psr7 · debian · 13
Observed:
References
- [https://github.com/advisories/GHSA-c2w2-prh8-qm98]
- [https://github.com/guzzle/psr7/commit/ddd64f17d4cc1f7e5ffe6fd2c989ec7221712580]
- [https://github.com/guzzle/psr7/pull/811]
- [https://github.com/guzzle/psr7/releases/tag/2.12.3]
- [https://github.com/guzzle/psr7/security/advisories/GHSA-c2w2-prh8-qm98]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-59882]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-59882]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-59882]
- [https://security-tracker.debian.org/tracker/CVE-2026-59882]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-59882.json]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]