
CVE catalog
CVE-2026-59886
pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the univ.Real type converted its mantissa, base, and exponent value to a Python float using exact big-integer exponentiation. A BER, CER,
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.62% · Oct 27, 2026
pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the univ.Real type converted its mantissa, base, and exponent value to a Python float using exact big-integer exponentiation. A BER, CER, or DER encoded REAL value only a few bytes long can carry a very large exponent, causing float conversion through prettyPrint(), str(), comparison, arithmetic, int(), or an explicit float() call to consume excessive CPU and memory and hang applications that decode untrusted ASN.1 data and then print, log, or compare decoded objects. This issue is fixed in version 0.6.4.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | pyasn1 | sid | 0.6.4-1 | fixed |
| Debian | pyasn1 | forky | 0.6.4-1 | fixed |
| Debian | pyasn1 | trixie | 0.6.1-1+deb13u3 | fixed |
| Debian | pyasn1 | trixie-security | 0.6.1-1+deb13u2 | vulnerable |
| Debian | pyasn1 | bookworm | 0.4.8-3+deb12u2 | vulnerable |
| Debian | pyasn1 | bookworm-security | 0.4.8-3+deb12u3 | fixed |
| Cpe | pyasn1 | Not reported | Not reported | vulnerable |
| Pip | pyasn1 | Not reported | 0.6.4 | fixed |
| PyPI | pyasn1 | Not reported | 0.6.4 | fixed |
| Ubuntu | pyasn1 | noble | 0.4.8-4ubuntu0.3 | fixed |
| Ubuntu | python-pyasn1-doc | noble | 0.4.8-4ubuntu0.3 | fixed |
| Ubuntu | python3-pyasn1 | noble | 0.4.8-4ubuntu0.3 | fixed |
| Ubuntu | pyasn1 | pro | 0.4.2-3 | vulnerable |
| Ubuntu | pyasn1 | pro | 0.4.2-3build1 | vulnerable |
| Ubuntu | pyasn1 | pro | 0.4.2-3ubuntu0.20.04.1~esm1 | vulnerable |
| Ubuntu | pyasn1 | 22.04 | 0.4.8-1 | vulnerable |
| Ubuntu | pyasn1 | 22.04 | 0.4.8-1ubuntu0.1 | vulnerable |
| Ubuntu | pyasn1 | 22.04 | 0.4.8-1ubuntu0.2 | vulnerable |
| Ubuntu | pyasn1 | 22.04 | 0.4.8-1ubuntu0.3 | fixed |
| Ubuntu | pyasn1 | 24.04 | 0.4.8-4 | vulnerable |
| Ubuntu | pyasn1 | 24.04 | 0.4.8-4ubuntu0.1 | vulnerable |
| Ubuntu | pyasn1 | 24.04 | 0.4.8-4ubuntu0.2 | vulnerable |
| Ubuntu | pyasn1 | 24.04 | 0.4.8-4ubuntu0.3 | fixed |
| Ubuntu | pyasn1 | 26.04 | 0.6.1-1 | vulnerable |
| Ubuntu | pyasn1 | 26.04 | 0.6.1-1build1 | vulnerable |
| Ubuntu | pyasn1 | 26.04 | 0.6.2-1 | vulnerable |
| Ubuntu | pyasn1 | 26.04 | 0.6.3-1 | vulnerable |
| Ubuntu | pyasn1 | 26.04 | 0.6.3-1ubuntu0.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | pyasn1 | source | sid | 0.6.4-1 | not yet assigned | Not reported | [1142388] |
| Debian | pyasn1 | source | forky | 0.6.4-1 | not yet assigned | Not reported | [1142388] |
| Debian | pyasn1 | source | trixie | 0.6.1-1+deb13u3 | not yet assigned | Not reported | [1142388] |
| Debian | pyasn1 | source | bookworm | 0.4.8-3+deb12u3 | not yet assigned | Not reported | [1142388] |
| Pip | pyasn1 | pip | Not reported | 0.6.4 | Not reported | Not reported | Not reported |
| PyPI | pyasn1 | PyPI | Not reported | 0.6.4 | Not reported | GHSA-HM4W-WWCW-MR6R | Not reported |
| Ubuntu | pyasn1 | deb | noble | 0.4.8-4ubuntu0.3 | Not reported | Not reported | Not reported |
| Ubuntu | python-pyasn1-doc | deb | noble | 0.4.8-4ubuntu0.3 | Not reported | Not reported | Not reported |
| Ubuntu | python3-pyasn1 | deb | noble | 0.4.8-4ubuntu0.3 | Not reported | Not reported | Not reported |
| Ubuntu | pyasn1 | deb | 22.04 | 0.4.8-1ubuntu0.3 | Not reported | UBUNTU-CVE-2026-59886 | Not reported |
| Ubuntu | pyasn1 | deb | 24.04 | 0.4.8-4ubuntu0.3 | Not reported | UBUNTU-CVE-2026-59886 | Not reported |
| Ubuntu | pyasn1 | deb | 26.04 | 0.6.3-1ubuntu0.1 | Not reported | UBUNTU-CVE-2026-59886 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [python3-pyasn1]Affected
Source package: [pyasn1]
Details (4)
0.4.8-3+deb12u2· all · bookwormAffected · Fixed:
0.4.8-3+deb12u3nvd · pyasn1 · debian · bookworm; nvd · pyasn1 · debian · 12
0.4.8-3+deb12u2· all · bookwormAffected · Fixed:
0.4.8-3+deb12u3nvd · pyasn1 · debian · bookworm; nvd · pyasn1 · debian · 12
0.4.8-3+deb12u2· all · bookworm-securityAffected · Fixed:
0.4.8-3+deb12u3nvd · pyasn1 · debian · bookworm; nvd · pyasn1 · debian · 12
0.4.8-3+deb12u2· all · bookworm-securityAffected · Fixed:
0.4.8-3+deb12u3nvd · pyasn1 · debian · bookworm; nvd · pyasn1 · debian · 12
- [python-pyasn1-doc]Affected
Source package: [pyasn1]
Details (4)
0.4.8-3+deb12u2· all · bookwormAffected · Fixed:
0.4.8-3+deb12u3nvd · pyasn1 · debian · bookworm; nvd · pyasn1 · debian · 12
0.4.8-3+deb12u2· all · bookwormAffected · Fixed:
0.4.8-3+deb12u3nvd · pyasn1 · debian · bookworm; nvd · pyasn1 · debian · 12
0.4.8-3+deb12u2· all · bookworm-securityAffected · Fixed:
0.4.8-3+deb12u3nvd · pyasn1 · debian · bookworm; nvd · pyasn1 · debian · 12
0.4.8-3+deb12u2· all · bookworm-securityAffected · Fixed:
0.4.8-3+deb12u3nvd · pyasn1 · debian · bookworm; nvd · pyasn1 · debian · 12
[Debian 13 (Trixie)]
- [python3-pyasn1]Affected
Source package: [pyasn1]
Details (6)
0.6.1-1+deb13u2· all · trixieAffected · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
0.6.1-1+deb13u2· all · trixieAffected · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
0.6.4-1~bpo13+1· all · trixie-backportsFixed · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
0.6.4-1~bpo13+1· all · trixie-backportsFixed · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
0.6.1-1+deb13u2· all · trixie-securityAffected · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
0.6.1-1+deb13u2· all · trixie-securityAffected · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
- [python-pyasn1-doc]Affected
Source package: [pyasn1]
Details (6)
0.6.1-1+deb13u2· all · trixieAffected · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
0.6.1-1+deb13u2· all · trixieAffected · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
0.6.4-1~bpo13+1· all · trixie-backportsFixed · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
0.6.4-1~bpo13+1· all · trixie-backportsFixed · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
0.6.1-1+deb13u2· all · trixie-securityAffected · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
0.6.1-1+deb13u2· all · trixie-securityAffected · Fixed:
0.6.1-1+deb13u3nvd · pyasn1 · debian · 13
Observed:
References
- [https://access.redhat.com/errata/RHSA-2026:56347]
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11318-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-59886]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-59886]
- [https://osv.dev/vulnerability/GHSA-hm4w-wwcw-mr6r]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-59886]
- [https://security-tracker.debian.org/tracker/CVE-2026-59886]
- [https://ubuntu.com/security/notices/USN-8712-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2748.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX] · [Ubuntu Security Notices (USN)]