
CVE catalog
CVE-2026-59898
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by
- Severity
- Medium · CVSS 6.3
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.44% · Oct 25, 2026
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | netty | sid | 1:4.1.48-16 | vulnerable |
| Debian | netty | forky | 1:4.1.48-16 | vulnerable |
| Debian | netty | trixie | 1:4.1.48-10+deb13u1 | vulnerable |
| Debian | netty | trixie-security | 1:4.1.48-10+deb13u1 | vulnerable |
| Debian | netty | bookworm | 1:4.1.48-7+deb12u2 | vulnerable |
| Debian | netty | bookworm-security | 1:4.1.48-7+deb12u2 | vulnerable |
| Maven | io.netty:netty-codec-http | Not reported | 4.2.16.Final | fixed |
| Maven | io.netty:netty-codec-http | Not reported | 4.1.136.Final | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | netty | source | sid | (unfixed) | not yet assigned | Not reported | [1143052] |
| Debian | netty | source | forky | (unfixed) | not yet assigned | Not reported | [1143052] |
| Debian | netty | source | trixie | (unfixed) | not yet assigned | Not reported | [1143052] |
| Debian | netty | source | bookworm | (unfixed) | not yet assigned | Not reported | [1143052] |
| Maven | io.netty:netty-codec-http | maven | Not reported | 4.2.16.Final | Not reported | Not reported | Not reported |
| Maven | io.netty:netty-codec-http | maven | Not reported | 4.1.136.Final | Not reported | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libnetty-java]Affected
Source package: [netty]
Details (4)
1:4.1.48-7+deb12u2· all · bookwormAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookwormAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
[Debian 13 (Trixie)]
- [libnetty-java]Affected
Source package: [netty]
Details (4)
1:4.1.48-10+deb13u1· all · trixieAffected
nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixieAffected
nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityAffected
nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityAffected
nvd · netty · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11394-1.json]
- [https://github.com/advisories/GHSA-4mp9-239f-g9hg]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-59898]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-59898]
- [https://security-tracker.debian.org/tracker/CVE-2026-59898]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-59898.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2356.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]