
CVE catalog
CVE-2026-61822
pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, run_maintenance() handles exceptions outside the loop that processes rows from part_config, so an ex
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.53% · Oct 25, 2026
pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, run_maintenance() handles exceptions outside the loop that processes rows from part_config, so an exception for one partition set immediately terminates the loop and skips every later set. A role with partman_user access can insert or update a row that reliably fails and assign it a low maintenance_order value so it is processed before legitimate rows. Repeated maintenance ticks then abort before legitimate partition sets are maintained, causing database-wide loss of automated partition maintenance. This issue is fixed in version 5.5.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | pg-partman | sid | 5.5.0-1 | fixed |
| Debian | pg-partman | forky | 5.5.0-1 | fixed |
| Debian | pg-partman | trixie | 5.2.4-1 | vulnerable |
| Debian | pg-partman | bookworm | 4.7.2-1 | vulnerable |
| Ubuntu | pg-partman | 16.04 | 2.2.2-1 | vulnerable |
| Ubuntu | pg-partman | 16.04 | 2.2.2-2 | vulnerable |
| Ubuntu | pg-partman | 18.04 | 2.6.3-1 | vulnerable |
| Ubuntu | pg-partman | 18.04 | 3.1.0-1 | vulnerable |
| Ubuntu | pg-partman | 18.04 | 3.1.1-1 | vulnerable |
| Ubuntu | pg-partman | 18.04 | 3.1.2-1 | vulnerable |
| Ubuntu | pg-partman | 20.04 | 4.0.0-1 | vulnerable |
| Ubuntu | pg-partman | 20.04 | 4.2.0-1 | vulnerable |
| Ubuntu | pg-partman | 20.04 | 4.2.2-1 | vulnerable |
| Ubuntu | pg-partman | 20.04 | 4.3.0-1 | vulnerable |
| Ubuntu | pg-partman | 22.04 | 4.5.1-1 | vulnerable |
| Ubuntu | pg-partman | 22.04 | 4.6.0-1 | vulnerable |
| Ubuntu | pg-partman | 24.04 | 4.7.3-1 | vulnerable |
| Ubuntu | pg-partman | 24.04 | 5.0.0-2 | vulnerable |
| Ubuntu | pg-partman | 24.04 | 5.0.1-1 | vulnerable |
| Ubuntu | pg-partman | 26.04 | 5.2.4-1 | vulnerable |
| Ubuntu | pg-partman | 26.04 | 5.3.1-2 | vulnerable |
| Ubuntu | pg-partman | 26.04 | 5.4.0-1 | vulnerable |
| Ubuntu | pg-partman | 26.04 | 5.4.1-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | pg-partman | source | sid | 5.5.0-1 | not yet assigned | Not reported | Not reported |
| Debian | pg-partman | source | forky | 5.5.0-1 | not yet assigned | Not reported | Not reported |
| Debian | pg-partman | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | pg-partman | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
Notes
[trixie] pg-partman: Minor issue [bookworm] pg-partman: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [postgresql-15-partman]Affected
Source package: [pg-partman]
Details (2)
4.7.2-1· amd64 · bookwormAffected
nvd · pg-partman · debian · bookworm; nvd · pg-partman · debian · 12
4.7.2-1· arm64 · bookwormAffected
nvd · pg-partman · debian · bookworm; nvd · pg-partman · debian · 12
[Debian 13 (Trixie)]
- [postgresql-17-partman]Affected
Source package: [pg-partman]
Details (2)
5.2.4-1· amd64 · trixieAffected
nvd · pg-partman · debian · 13
5.2.4-1· arm64 · trixieAffected
nvd · pg-partman · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-61822]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-61822]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-61822]
- [https://security-tracker.debian.org/tracker/CVE-2026-61822]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-61822.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2493.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]