
CVE catalog
CVE-2026-62243
netty: CVE-2026-62243
- Severity
- High · CVSS 8.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.15% · Oct 27, 2026
Netty (io.netty:netty-handler) versions from 4.2.0.Final through 4.2.16.Final and versions through 4.1.136.Final disable TLS hostname verification on the SslProvider.OPENSSL client path when a plain (non-extended) X509TrustManager is used and Unsafe-based trust-manager wrapping is unavailable (Java 25+). In this configuration the OpenSSL client does not perform hostname verification, allowing a man-in-the-middle attacker to present a certificate issued for a different hostname that is accepted without validation. Fixed in 4.2.17.Final and 4.1.137.Final.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | netty | sid | 1:4.1.48-16 | vulnerable |
| Debian | netty | forky | 1:4.1.48-16 | vulnerable |
| Debian | netty | trixie | 1:4.1.48-10+deb13u1 | vulnerable |
| Debian | netty | trixie-security | 1:4.1.48-10+deb13u1 | vulnerable |
| Debian | netty | bookworm | 1:4.1.48-7+deb12u2 | vulnerable |
| Debian | netty | bookworm-security | 1:4.1.48-7+deb12u2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | netty | source | sid | (unfixed) | not yet assigned | Not reported | [1145167] |
| Debian | netty | source | forky | (unfixed) | not yet assigned | Not reported | [1145167] |
| Debian | netty | source | trixie | (unfixed) | not yet assigned | Not reported | [1145167] |
| Debian | netty | source | bookworm | (unfixed) | not yet assigned | Not reported | [1145167] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libnetty-java]Affected
Source package: [netty]
Details (4)
1:4.1.48-7+deb12u2· all · bookwormAffected
dsa · netty · debian · bookworm
1:4.1.48-7+deb12u2· all · bookwormAffected
dsa · netty · debian · bookworm
1:4.1.48-7+deb12u2· all · bookworm-securityAffected
dsa · netty · debian · bookworm
1:4.1.48-7+deb12u2· all · bookworm-securityAffected
dsa · netty · debian · bookworm
Observed:
References
- [https://access.redhat.com/errata/RHSA-2026:66488]
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11882-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-62243]
- [https://osv.dev/vulnerability/CVE-2026-62243]
- [https://security-tracker.debian.org/tracker/CVE-2026-62243]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2712.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]