
CVE catalog
CVE-2026-62322
social-auth-core: CVE-2026-62322
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.15% · Oct 25, 2026
Python Social Auth is a social authentication/registration mechanism. Prior to 5.0.2, the LINE backend exchanges an authorization code without validating the returned OAuth state. An attacker can begin authorization for an attacker-controlled LINE account and induce a victim to visit the resulting callback URL, causing the application to log the victim into the attacker's account. When account linking is enabled, the same missing validation can link the attacker's LINE identity to the victim's existing account and create a persistent unauthorized login path. Only applications with the LINE backend enabled are affected. This issue is fixed in version 5.0.2.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | social-auth-core | sid | 5.1.1-1 | fixed |
| Debian | social-auth-core | forky | 5.1.1-1 | fixed |
| Debian | social-auth-core | trixie | 4.6.1-1 | vulnerable |
| Debian | social-auth-core | bookworm | 4.3.0-1 | vulnerable |
| PyPI | social-auth-core | Not reported | 0.0.1 | vulnerable |
| PyPI | social-auth-core | Not reported | 0.1.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 0.2.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 0.2.1 | vulnerable |
| PyPI | social-auth-core | Not reported | 1.0.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 1.0.1 | vulnerable |
| PyPI | social-auth-core | Not reported | 1.1.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 1.2.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 1.3.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 1.4.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 1.5.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 1.6.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 1.7.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 2.0.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 3.0.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 3.1.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 3.2.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 3.3.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 3.3.1 | vulnerable |
| PyPI | social-auth-core | Not reported | 3.3.2 | vulnerable |
| PyPI | social-auth-core | Not reported | 3.3.3 | vulnerable |
| PyPI | social-auth-core | Not reported | 3.4.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.0.2 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.0.3 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.1.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.2.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.3.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.4.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.4.1 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.4.2 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.5.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.5.1 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.5.2 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.5.3 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.5.4 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.5.5 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.5.6 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.6.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.6.1 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.7.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.8.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.8.1 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.8.2 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.8.3 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.8.4 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.8.5 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.8.6 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.8.7 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.9.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 4.9.1 | vulnerable |
| PyPI | social-auth-core | Not reported | 5.0.0 | vulnerable |
| PyPI | social-auth-core | Not reported | 5.0.1 | vulnerable |
| PyPI | social-auth-core | Not reported | 5.0.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | social-auth-core | source | sid | 5.0.2-1 | not yet assigned | Not reported | Not reported |
| Debian | social-auth-core | source | forky | 5.0.2-1 | not yet assigned | Not reported | Not reported |
| Debian | social-auth-core | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | social-auth-core | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| PyPI | social-auth-core | PyPI | Not reported | 5.0.2 | Not reported | GHSA-526J-582W-7FM9 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [python3-social-auth-core]Affected
Source package: [social-auth-core]
Details (2)
4.3.0-1· all · bookwormAffected
dsa · social-auth-core · debian · bookworm; dsa · social-auth-core · debian · 12
4.3.0-1· all · bookwormAffected
dsa · social-auth-core · debian · bookworm; dsa · social-auth-core · debian · 12
[Debian 13 (Trixie)]
- [python3-social-auth-core]Affected
Source package: [social-auth-core]
Details (2)
4.6.1-1· all · trixieAffected
dsa · social-auth-core · debian · 13
4.6.1-1· all · trixieAffected
dsa · social-auth-core · debian · 13
Observed:
References
- [https://github.com/advisories/GHSA-526j-582w-7fm9]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-62322]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-62322]
- [https://osv.dev/vulnerability/GHSA-526j-582w-7fm9]
- [https://security-tracker.debian.org/tracker/CVE-2026-62322]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-62322.json]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]