
CVE catalog
CVE-2026-62364
wlc: CVE-2026-62364
- Severity
- Low · CVSS 2.3
CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.08% · Oct 25, 2026
wlc is a Weblate command-line client using Weblate's REST API. Prior to 2.0.1, automatically discovered configuration from .weblate, .weblate.ini, or weblate.ini can select the API URL while an unscoped API token is supplied through WLC_KEY or --key without a matching WLC_URL or --url. When wlc runs in an untrusted repository, pull request checkout, or directory with untrusted ancestor configuration, it can send the token to an attacker-controlled project-configured URL. URL-scoped keys in [keys] are not affected. This issue is fixed in version 2.0.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | wlc | sid | 2.2.1-1 | fixed |
| Debian | wlc | forky | 2.2.1-1 | fixed |
| Debian | wlc | trixie | 1.15-1 | vulnerable |
| Debian | wlc | bookworm | 1.13-2 | vulnerable |
| Pip | wlc | Not reported | 2.0.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | wlc | source | sid | 2.2.1-1 | not yet assigned | Not reported | [1148878] |
| Debian | wlc | source | forky | 2.2.1-1 | not yet assigned | Not reported | [1148878] |
| Debian | wlc | source | trixie | (unfixed) | not yet assigned | Not reported | [1148878] |
| Debian | wlc | source | bookworm | (unfixed) | not yet assigned | Not reported | [1148878] |
| Pip | wlc | pip | Not reported | 2.0.1 | Not reported | GHSA-3MQQ-HV9C-85HC | Not reported |
Notes
[trixie] wlc: Minor issue [bookworm] wlc: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [wlc]Affected
Details (2)
1.13-2· all · bookwormAffected
dsa · wlc · debian · bookworm; dsa · wlc · debian · 12
1.13-2· all · bookwormAffected
dsa · wlc · debian · bookworm; dsa · wlc · debian · 12
[Debian 13 (Trixie)]
- [wlc]Affected
Details (2)
1.15-1· all · trixieAffected
dsa · wlc · debian · 13
1.15-1· all · trixieAffected
dsa · wlc · debian · 13
Observed:
References
- [https://github.com/advisories/GHSA-3mqq-hv9c-85hc]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-62364]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-62364]
- [https://security-tracker.debian.org/tracker/CVE-2026-62364]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]