
CVE catalog
CVE-2026-64677
UBUNTU-CVE-2026-64677
- Severity
- Medium · CVSS 5.9
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.02% · Oct 27, 2026
Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, endpoints in Anki's local HTTP server do not adequately constrain requested media and built-in data paths, allowing scripts served from shared decks, or malicious websites combined with an origin-check bypass, to read local files through directory traversal. This issue is fixed in version 25.09.3.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | anki | 16.04 | 2.0.32+dfsg-1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~a12-0.1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~b24-1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~b25-1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~b26-1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~b27-1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~b29-1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~b31-1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~b33-1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~b34-1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~b35-1 | vulnerable |
| Ubuntu | anki | 18.04 | 2.1.0+dfsg~b36-1 | vulnerable |
| Ubuntu | anki | 20.04 | 2.1.8+dfsg-1ubuntu1 | vulnerable |
| Ubuntu | anki | 20.04 | 2.1.15+dfsg-1 | vulnerable |
| Ubuntu | anki | 22.04 | 2.1.15+dfsg-3 | vulnerable |
| Ubuntu | anki | 22.04 | 2.1.15+dfsg-3ubuntu0.1 | vulnerable |
| Ubuntu | anki | 24.04 | 2.1.15+dfsg-3ubuntu1 | vulnerable |
| Ubuntu | anki | 24.04 | 2.1.15+dfsg-3ubuntu2 | vulnerable |
| Ubuntu | anki | 24.04 | 2.1.15+dfsg-3ubuntu3 | vulnerable |
| Ubuntu | anki | 24.04 | 2.1.15+dfsg-3ubuntu4 | vulnerable |
| Ubuntu | anki | 24.04 | 2.1.15+dfsg-3ubuntu4.1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://github.com/ankitects/anki/commit/f4692e54a4fafc89528afab1983f0b98d593023f]
- [https://github.com/ankitects/anki/security/advisories/GHSA-78wr-2gg2-4hqg]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-64677]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-64677]
[FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]