
CVE catalog
CVE-2026-66074
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, match_value/3 passes the user-supplied ?name= regular expression to re:run with no match_limi
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.39% · Oct 25, 2026
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, match_value/3 passes the user-supplied ?name= regular expression to re:run with no match_limit option, and executes it once per resource in the result set. OTP's default 10M match_limit caps each call at roughly 100-200ms, but the regex runs once per resource in the result set. With a large set, for example 5000 queues at 150ms each, a single request consumes 12 or more minutes of CPU. Parallel requests saturate the schedulers. The use_regex=true option is a supported feature on list endpoints, so this path is reachable through normal API use. Preconditions include Any user with the management tag can exploit this.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rabbitmq-server | sid | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | forky | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | trixie | 4.0.5-6+deb13u2 | vulnerable |
| Debian | rabbitmq-server | bookworm | 3.10.8-1.1+deb12u1 | vulnerable |
| Debian | rabbitmq-server | bookworm-security | 3.10.8-1.1+deb12u1 | vulnerable |
| Cpe | rabbitmq_server | Not reported | 4.2.6 | fixed |
| Ubuntu | rabbitmq-server | pro | 3.7.8-4ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.7.18-1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.3 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.5 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3+esm1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3+esm2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.8.9-3ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-3 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-5 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-6 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1ubuntu0.22.04.1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1ubuntu0.22.04.2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.5 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.6 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.6 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.7 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-8ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu3 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu4 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5.1 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5.2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rabbitmq-server | source | sid | 4.3.0-2 | not yet assigned | Not reported | Not reported |
| Debian | rabbitmq-server | source | forky | 4.3.0-2 | not yet assigned | Not reported | Not reported |
| Debian | rabbitmq-server | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | rabbitmq-server | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Cpe | rabbitmq_server | cpe | Not reported | 4.2.6 | Not reported | NVD-CVE-2026-66074 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [rabbitmq-server]Affected
Details (4)
3.10.8-1.1+deb12u1· all · bookwormAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookwormAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookworm-securityAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookworm-securityAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
[Debian 13 (Trixie)]
- [rabbitmq-server]Affected
Details (2)
4.0.5-6+deb13u2· all · trixieAffected
nvd · rabbitmq-server · debian · 13
4.0.5-6+deb13u2· all · trixieAffected
nvd · rabbitmq-server · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-66074]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-66074]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-66074]
- [https://security-tracker.debian.org/tracker/CVE-2026-66074]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-66074.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2268.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]