
CVE catalog
CVE-2026-66080
RabbitMQ is a messaging and streaming broker. Prior to versions 4.1.11, 4.2.6, and 4.3.0, validate_partitions only checks that the requested partition count is at least 1, with no upper bound. A large
- Severity
- Medium · CVSS 5.9
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.32% · Oct 25, 2026
RabbitMQ is a messaging and streaming broker. Prior to versions 4.1.11, 4.2.6, and 4.3.0, validate_partitions only checks that the requested partition count is at least 1, with no upper bound. A large count such as lists:seq(0, 500000000) allocates roughly 8GB. Preconditions include The rabbitmq_stream_management plugin must be enabled. The caller needs the management tag and access to the target vhost.. This issue is fixed in versions 4.1.11, 4.2.6, and 4.3.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rabbitmq-server | sid | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | forky | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | trixie | 4.0.5-6+deb13u2 | vulnerable |
| Debian | rabbitmq-server | bookworm | 3.10.8-1.1+deb12u1 | not affected |
| Debian | rabbitmq-server | bookworm-security | 3.10.8-1.1+deb12u1 | not affected |
| Cpe | rabbitmq_server | Not reported | 4.2.6 | fixed |
| Ubuntu | rabbitmq-server | pro | 3.7.8-4ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.7.18-1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.3 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.5 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3+esm1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3+esm2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.8.9-3ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-3 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-5 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-6 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1ubuntu0.22.04.1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1ubuntu0.22.04.2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.5 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.6 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.6 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.7 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-8ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu3 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu4 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5.1 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5.2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rabbitmq-server | source | sid | 4.3.0-2 | not yet assigned | Not reported | Not reported |
| Debian | rabbitmq-server | source | forky | 4.3.0-2 | not yet assigned | Not reported | Not reported |
| Debian | rabbitmq-server | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | rabbitmq-server | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Cpe | rabbitmq_server | cpe | Not reported | 4.2.6 | Not reported | NVD-CVE-2026-66080 | Not reported |
OpenFactory catalog packages
[Debian 13 (Trixie)]
- [rabbitmq-server]Affected
Details (2)
4.0.5-6+deb13u2· all · trixieAffected
nvd · rabbitmq-server · debian · 13
4.0.5-6+deb13u2· all · trixieAffected
nvd · rabbitmq-server · debian · 13
[Debian 12 (Bookworm)]
- [rabbitmq-server]Not affected
Details (4)
3.10.8-1.1+deb12u1· all · bookwormNot affected
nvd · rabbitmq-server · debian · bookworm
3.10.8-1.1+deb12u1· all · bookwormNot affected
nvd · rabbitmq-server · debian · bookworm
3.10.8-1.1+deb12u1· all · bookworm-securityNot affected
nvd · rabbitmq-server · debian · bookworm
3.10.8-1.1+deb12u1· all · bookworm-securityNot affected
nvd · rabbitmq-server · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-66080]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-66080]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-66080]
- [https://security-tracker.debian.org/tracker/CVE-2026-66080]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-66080.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]