
CVE catalog
CVE-2026-6681
The PKCS#7 decode path ignores the caller-supplied output buffer size (outputSz), allowing decoded content to be written past the bounds of the provided buffer. This affects wolfSSL 5.9.0 and earlier
- Severity
- Low · CVSS 1
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.38% · Oct 25, 2026
The PKCS#7 decode path ignores the caller-supplied output buffer size (outputSz), allowing decoded content to be written past the bounds of the provided buffer. This affects wolfSSL 5.9.0 and earlier and was fixed in the 5.9.1 release.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | wolfssl | sid | 5.9.2-1.2 | fixed |
| Debian | wolfssl | trixie | 5.7.2-0.1+deb13u2 | fixed |
| Debian | wolfssl | bookworm | 5.5.4-2+deb12u2 | vulnerable |
| Debian | wolfssl | bookworm-security | 5.5.4-2+deb12u3 | fixed |
| Cpe | wolfssl | Not reported | Not reported | vulnerable |
| Cpe | wolfssl | Not reported | 5.9.1 | fixed |
| Ubuntu | wolfssl | 16.04 | 3.4.8+dfsg-1 | vulnerable |
| Ubuntu | wolfssl | 18.04 | 3.10.2+dfsg-2 | vulnerable |
| Ubuntu | wolfssl | 18.04 | 3.12.0+dfsg-1 | vulnerable |
| Ubuntu | wolfssl | 18.04 | 3.12.2+dfsg-1 | vulnerable |
| Ubuntu | wolfssl | 18.04 | 3.13.0+dfsg-1 | vulnerable |
| Ubuntu | wolfssl | 20.04 | 4.1.0+dfsg-2 | vulnerable |
| Ubuntu | wolfssl | 20.04 | 4.2.0+dfsg-1 | vulnerable |
| Ubuntu | wolfssl | 20.04 | 4.2.0+dfsg-2 | vulnerable |
| Ubuntu | wolfssl | 20.04 | 4.2.0+dfsg-3 | vulnerable |
| Ubuntu | wolfssl | 20.04 | 4.3.0+dfsg-2 | vulnerable |
| Ubuntu | wolfssl | 22.04 | 4.6.0-3 | vulnerable |
| Ubuntu | wolfssl | 22.04 | 5.0.0-1 | vulnerable |
| Ubuntu | wolfssl | 22.04 | 5.1.1-1 | vulnerable |
| Ubuntu | wolfssl | 22.04 | 5.2.0-1 | vulnerable |
| Ubuntu | wolfssl | 22.04 | 5.2.0-2 | vulnerable |
| Ubuntu | wolfssl | 24.04 | 5.5.4-2 | vulnerable |
| Ubuntu | wolfssl | 24.04 | 5.5.4-2.1 | vulnerable |
| Ubuntu | wolfssl | 24.04 | 5.6.4-2 | vulnerable |
| Ubuntu | wolfssl | 24.04 | 5.6.6-1.2 | vulnerable |
| Ubuntu | wolfssl | 24.04 | 5.6.6-1.3 | vulnerable |
| Ubuntu | wolfssl | 24.04 | 5.6.6-1.3build1 | vulnerable |
| Ubuntu | wolfssl | 25.10 | 5.7.2-0.1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | wolfssl | source | sid | 5.9.2-1 | not yet assigned | Not reported | Not reported |
| Debian | wolfssl | source | trixie | 5.7.2-0.1+deb13u2 | not yet assigned | Not reported | Not reported |
| Debian | wolfssl | source | bookworm | 5.5.4-2+deb12u3 | not yet assigned | Not reported | Not reported |
| Cpe | wolfssl | cpe | Not reported | 5.9.1 | Not reported | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libwolfssl35]Affected
Source package: [wolfssl]
Details (4)
5.5.4-2+deb12u2· amd64 · bookwormAffected · Fixed:
5.5.4-2+deb12u3nvd · wolfssl · debian · bookworm; nvd · wolfssl · debian · 12
5.5.4-2+deb12u2· arm64 · bookwormAffected · Fixed:
5.5.4-2+deb12u3nvd · wolfssl · debian · bookworm; nvd · wolfssl · debian · 12
5.5.4-2+deb12u3· amd64 · bookworm-securityFixed · Fixed:
5.5.4-2+deb12u3nvd · wolfssl · debian · bookworm; nvd · wolfssl · debian · 12
5.5.4-2+deb12u3· arm64 · bookworm-securityFixed · Fixed:
5.5.4-2+deb12u3nvd · wolfssl · debian · bookworm; nvd · wolfssl · debian · 12
- [libwolfssl-dev]Affected
Source package: [wolfssl]
Details (4)
5.5.4-2+deb12u2· amd64 · bookwormAffected · Fixed:
5.5.4-2+deb12u3nvd · wolfssl · debian · bookworm; nvd · wolfssl · debian · 12
5.5.4-2+deb12u2· arm64 · bookwormAffected · Fixed:
5.5.4-2+deb12u3nvd · wolfssl · debian · bookworm; nvd · wolfssl · debian · 12
5.5.4-2+deb12u3· amd64 · bookworm-securityFixed · Fixed:
5.5.4-2+deb12u3nvd · wolfssl · debian · bookworm; nvd · wolfssl · debian · 12
5.5.4-2+deb12u3· arm64 · bookworm-securityFixed · Fixed:
5.5.4-2+deb12u3nvd · wolfssl · debian · bookworm; nvd · wolfssl · debian · 12
[Debian 13 (Trixie)]
- [libwolfssl42t64]Affected
Source package: [wolfssl]
Details (2)
5.7.2-0.1+deb13u1· amd64 · trixieAffected · Fixed:
5.7.2-0.1+deb13u2nvd · wolfssl · debian · 13
5.7.2-0.1+deb13u1· arm64 · trixieAffected · Fixed:
5.7.2-0.1+deb13u2nvd · wolfssl · debian · 13
- [libwolfssl-dev]Affected
Source package: [wolfssl]
Details (2)
5.7.2-0.1+deb13u1· amd64 · trixieAffected · Fixed:
5.7.2-0.1+deb13u2nvd · wolfssl · debian · 13
5.7.2-0.1+deb13u1· arm64 · trixieAffected · Fixed:
5.7.2-0.1+deb13u2nvd · wolfssl · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-6681]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-6681]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-6681]
- [https://security-tracker.debian.org/tracker/CVE-2026-6681]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]