CVE catalog

CVE-2026-67218

RabbitMQ is a messaging and streaming broker. Prior to…

[CVE catalog]

RabbitMQ is a messaging and streaming broker. Prior to versions 4.0.22, 4.1.11, 4.2.6, and 4.3.0, accept_content/2 at line 56 calls rabbit_stream_manager:create_super_stream/... directly after is_authorized (which only checks the management tag + vhost access via is_authorized_vhost). The stream-protocol equivalent (rabbit_stream_reader.erl create_super_stream handler) calls rabbit_stream_utils:check_super_stream_management_permitted/4 which enforces configure on the exchange and each partition queue. The HTTP handler omits this call entirely. A user with management tag and vhost access , but no configure permission on any resource , can create super-streams (an exchange + N partition stream queues + bindings) via the HTTP API. The native stream-protocol path enforces configure on each resource; the HTTP path does not, creating a privilege escalation from 'can view' to 'can create persistent cluster-wide resources.' Preconditions include rabbitmq_stream_management plugin enabled management tag + vhost access (no resource permissions needed). This issue is fixed in versions 4.0.22, 4.1.11, 4.2.6, and 4.3.0.

Severity
Medium · CVSS 4.3CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Published
Updated
Source
[NVD] · [CVE record]
EPSS
0.37% · Oct 27, 2026

Projects and upstream resources

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Version impact has not been established. The original provider fields are retained below.

Provider details and historical evidence
Original provider fields
{
  "package_releases": [
    {
      "name": "rabbitmq-server",
      "status": "fixed",
      "release": "sid",
      "version": "4.3.6-1"
    },
    {
      "name": "rabbitmq-server",
      "status": "fixed",
      "release": "forky",
      "version": "4.3.6-1"
    },
    {
      "name": "rabbitmq-server",
      "status": "vulnerable",
      "release": "trixie",
      "version": "4.0.5-6+deb13u2"
    },
    {
      "name": "rabbitmq-server",
      "status": "not affected",
      "release": "bookworm",
      "version": "3.10.8-1.1+deb12u1"
    },
    {
      "name": "rabbitmq-server",
      "status": "not affected",
      "release": "bookworm-security",
      "version": "3.10.8-1.1+deb12u1"
    }
  ],
  "fixed_versions": [
    {
      "bug": null,
      "name": "rabbitmq-server",
      "type": "source",
      "origin": null,
      "release": "sid",
      "urgency": "not yet assigned",
      "fixed_version": "4.3.0-2"
    },
    {
      "bug": null,
      "name": "rabbitmq-server",
      "type": "source",
      "origin": null,
      "release": "forky",
      "urgency": "not yet assigned",
      "fixed_version": "4.3.0-2"
    },
    {
      "bug": null,
      "name": "rabbitmq-server",
      "type": "source",
      "origin": null,
      "release": "trixie",
      "urgency": "not yet assigned",
      "fixed_version": ""
    },
    {
      "bug": null,
      "name": "rabbitmq-server",
      "type": "source",
      "origin": null,
      "release": "bookworm",
      "urgency": "unimportant",
      "fixed_version": "0"
    }
  ],
  "distribution_packages": [
    {
      "name": "rabbitmq_server",
      "ranges": [
        {
          "fixed": "4.2.6",
          "introduced": "4.2.0",
          "last_affected": "",
          "start_excluding": ""
        }
      ],
      "ecosystem": "cpe",
      "fixed_version": "4.2.6",
      "provider_record_id": "NVD-CVE-2026-67218"
    },
    {
      "name": "rabbitmq-server",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            }
          ]
        }
      ],
      "release": "pro",
      "versions": [
        "3.7.8-4ubuntu2",
        "3.7.18-1",
        "3.8.2-0ubuntu1",
        "3.8.2-0ubuntu1.1",
        "3.8.2-0ubuntu1.2",
        "3.8.2-0ubuntu1.3",
        "3.8.2-0ubuntu1.4",
        "3.8.2-0ubuntu1.5",
        "3.8.3-0ubuntu0.1",
        "3.8.3-0ubuntu0.2",
        "3.8.3-0ubuntu0.3",
        "3.8.3-0ubuntu0.3+esm1",
        "3.8.3-0ubuntu0.3+esm2"
      ],
      "ecosystem": "deb",
      "fixed_version": "",
      "provider_record_id": "UBUNTU-CVE-2026-67218"
    },
    {
      "name": "rabbitmq-server",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            }
          ]
        }
      ],
      "release": "22.04",
      "versions": [
        "3.8.9-3ubuntu1",
        "3.9.8-1",
        "3.9.8-2",
        "3.9.8-3",
        "3.9.8-5",
        "3.9.8-6",
        "3.9.13-1",
        "3.9.13-1ubuntu0.22.04.1",
        "3.9.13-1ubuntu0.22.04.2",
        "3.9.27-0ubuntu0.1",
        "3.9.27-0ubuntu0.2",
        "3.9.27-0ubuntu0.5",
        "3.9.27-0ubuntu0.6"
      ],
      "ecosystem": "deb",
      "fixed_version": "",
      "provider_record_id": "UBUNTU-CVE-2026-67218"
    },
    {
      "name": "rabbitmq-server",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            }
          ]
        }
      ],
      "release": "24.04",
      "versions": [
        "3.12.1-1",
        "3.12.1-1ubuntu1",
        "3.12.1-1ubuntu1.2",
        "3.12.1-1ubuntu1.4",
        "3.12.1-1ubuntu1.6",
        "3.12.1-1ubuntu1.7"
      ],
      "ecosystem": "deb",
      "fixed_version": "",
      "provider_record_id": "UBUNTU-CVE-2026-67218"
    },
    {
      "name": "rabbitmq-server",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            }
          ]
        }
      ],
      "release": "26.04",
      "versions": [
        "4.0.5-8ubuntu2",
        "4.0.5-10ubuntu1",
        "4.0.5-10ubuntu2",
        "4.0.5-10ubuntu3",
        "4.0.5-10ubuntu4",
        "4.0.5-10ubuntu5",
        "4.0.5-10ubuntu5.1",
        "4.0.5-10ubuntu5.2"
      ],
      "ecosystem": "deb",
      "fixed_version": "",
      "provider_record_id": "UBUNTU-CVE-2026-67218"
    }
  ]
}

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

[Debian 12 (Bookworm)]

  • Details (4)
    • 3.10.8-1.1+deb12u1 · all · bookworm

      Not affected

      nvd · rabbitmq-server · debian · bookworm

    • 3.10.8-1.1+deb12u1 · all · bookworm

      Not affected

      nvd · rabbitmq-server · debian · bookworm

    • 3.10.8-1.1+deb12u1 · all · bookworm-security

      Not affected

      nvd · rabbitmq-server · debian · bookworm

    • 3.10.8-1.1+deb12u1 · all · bookworm-security

      Not affected

      nvd · rabbitmq-server · debian · bookworm

[Debian 13 (Trixie)]

  • Details (2)
    • 4.0.5-6+deb13u2 · all · trixie

      Affected

      nvd · rabbitmq-server · debian · 13

    • 4.0.5-6+deb13u2 · all · trixie

      Affected

      nvd · rabbitmq-server · debian · 13

Observed:

References