
CVE catalog
CVE-2026-67221
RabbitMQ is a messaging and streaming broker. Prior to…
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The AMQP 0-9-1 shovel calls amqp_uri:remove_credentials before storing its connection URI, but the AMQP 1.0 shovel stores the raw URI including the password. The stored URI is visible via GET /api/shovels and via rabbitmqctl shovel_status. Preconditions include The Shovel plugin must be in use with AMQP 1.0 shovels configured using URI-embedded credentials. Reading the exposed status requires the monitoring tag.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
- Severity
- Medium · CVSS 5.9
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.19% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [
{
"name": "rabbitmq-server",
"status": "fixed",
"release": "sid",
"version": "4.3.6-1"
},
{
"name": "rabbitmq-server",
"status": "fixed",
"release": "forky",
"version": "4.3.6-1"
},
{
"name": "rabbitmq-server",
"status": "vulnerable",
"release": "trixie",
"version": "4.0.5-6+deb13u2"
},
{
"name": "rabbitmq-server",
"status": "vulnerable",
"release": "bookworm",
"version": "3.10.8-1.1+deb12u1"
},
{
"name": "rabbitmq-server",
"status": "vulnerable",
"release": "bookworm-security",
"version": "3.10.8-1.1+deb12u1"
}
],
"fixed_versions": [
{
"bug": null,
"name": "rabbitmq-server",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "4.3.0-2"
},
{
"bug": null,
"name": "rabbitmq-server",
"type": "source",
"origin": null,
"release": "forky",
"urgency": "not yet assigned",
"fixed_version": "4.3.0-2"
},
{
"bug": null,
"name": "rabbitmq-server",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "not yet assigned",
"fixed_version": ""
},
{
"bug": null,
"name": "rabbitmq-server",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": ""
}
],
"distribution_packages": [
{
"name": "rabbitmq_server",
"ranges": [
{
"fixed": "4.2.6",
"introduced": "4.2.0",
"last_affected": "",
"start_excluding": ""
}
],
"ecosystem": "cpe",
"fixed_version": "4.2.6",
"provider_record_id": "NVD-CVE-2026-67221"
},
{
"name": "rabbitmq-server",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "pro",
"versions": [
"3.7.8-4ubuntu2",
"3.7.18-1",
"3.8.2-0ubuntu1",
"3.8.2-0ubuntu1.1",
"3.8.2-0ubuntu1.2",
"3.8.2-0ubuntu1.3",
"3.8.2-0ubuntu1.4",
"3.8.2-0ubuntu1.5",
"3.8.3-0ubuntu0.1",
"3.8.3-0ubuntu0.2",
"3.8.3-0ubuntu0.3",
"3.8.3-0ubuntu0.3+esm1",
"3.8.3-0ubuntu0.3+esm2"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-67221"
},
{
"name": "rabbitmq-server",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "22.04",
"versions": [
"3.8.9-3ubuntu1",
"3.9.8-1",
"3.9.8-2",
"3.9.8-3",
"3.9.8-5",
"3.9.8-6",
"3.9.13-1",
"3.9.13-1ubuntu0.22.04.1",
"3.9.13-1ubuntu0.22.04.2",
"3.9.27-0ubuntu0.1",
"3.9.27-0ubuntu0.2",
"3.9.27-0ubuntu0.5",
"3.9.27-0ubuntu0.6"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-67221"
},
{
"name": "rabbitmq-server",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "24.04",
"versions": [
"3.12.1-1",
"3.12.1-1ubuntu1",
"3.12.1-1ubuntu1.2",
"3.12.1-1ubuntu1.4",
"3.12.1-1ubuntu1.6",
"3.12.1-1ubuntu1.7"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-67221"
},
{
"name": "rabbitmq-server",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "26.04",
"versions": [
"4.0.5-8ubuntu2",
"4.0.5-10ubuntu1",
"4.0.5-10ubuntu2",
"4.0.5-10ubuntu3",
"4.0.5-10ubuntu4",
"4.0.5-10ubuntu5",
"4.0.5-10ubuntu5.1",
"4.0.5-10ubuntu5.2"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-67221"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [rabbitmq-server]Unknown
Details (4)
3.10.8-1.1+deb12u1· all · bookwormAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookwormAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookworm-securityAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookworm-securityAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
[Debian 13 (Trixie)]
- [rabbitmq-server]Unknown
Details (2)
4.0.5-6+deb13u2· all · trixieAffected
nvd · rabbitmq-server · debian · 13
4.0.5-6+deb13u2· all · trixieAffected
nvd · rabbitmq-server · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-67221]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-67221]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-67221]
- [https://security-tracker.debian.org/tracker/CVE-2026-67221]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-67221.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2268.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]