
CVE catalog
CVE-2026-67232
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The cowboy WebSocket options at line 117 set compress => true, enabling RFC 7692 permessage-d
- Severity
- Critical · CVSS 9.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.39% · Oct 25, 2026
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The cowboy WebSocket options at line 117 set compress => true, enabling RFC 7692 permessage-deflate negotiation. The handler does not set max_frame_size, so cowboy's default of infinity applies. cowlib's cow_ws:parse_payload/9 calls zlib:inflate/2 on the compressed payload with no output-size limit. An attacker can negotiate permessage-deflate during the WebSocket upgrade and send a frame containing a zlib bomb (e.g. 50 KB → 5 GB). Decompression occurs in the connection process before websocket_handle/2 ever sees the MQTT bytes. An unauthenticated attacker can crash a RabbitMQ node running the Web-MQTT plugin by sending a single highly-compressed WebSocket frame (a few KB on the wire) that inflates to gigabytes in memory. The cowboy WebSocket handler decompresses the entire frame before the MQTT CONNECT packet is processed, so no credentials are required. Preconditions include rabbitmq_web_mqtt plugin enabled (not default, but common for browser clients) Network reachability to port 15675/15676 No authentication required. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rabbitmq-server | sid | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | forky | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | trixie | 4.0.5-6+deb13u2 | vulnerable |
| Debian | rabbitmq-server | bookworm | 3.10.8-1.1+deb12u1 | vulnerable |
| Debian | rabbitmq-server | bookworm-security | 3.10.8-1.1+deb12u1 | vulnerable |
| Ubuntu | rabbitmq-server | noble | 3.12.1-1ubuntu1.7 | fixed |
| Cpe | rabbitmq_server | Not reported | 4.2.6 | fixed |
| Ubuntu | rabbitmq-server | pro | 3.7.8-4ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.7.18-1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.3 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.5 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3+esm1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3+esm2 | fixed |
| Ubuntu | rabbitmq-server | 22.04 | 3.8.9-3ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-3 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-5 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-6 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1ubuntu0.22.04.1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1ubuntu0.22.04.2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.5 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.6 | fixed |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.6 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.7 | fixed |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-8ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu3 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu4 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5.1 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rabbitmq-server | source | sid | 4.3.0-2 | not yet assigned | Not reported | Not reported |
| Debian | rabbitmq-server | source | forky | 4.3.0-2 | not yet assigned | Not reported | Not reported |
| Debian | rabbitmq-server | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | rabbitmq-server | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Ubuntu | rabbitmq-server | deb | noble | 3.12.1-1ubuntu1.7 | Not reported | Not reported | Not reported |
| Cpe | rabbitmq_server | cpe | Not reported | 4.2.6 | Not reported | NVD-CVE-2026-67232 | Not reported |
| Ubuntu | rabbitmq-server | deb | pro | 3.8.3-0ubuntu0.3+esm2 | Not reported | UBUNTU-CVE-2026-67232 | Not reported |
| Ubuntu | rabbitmq-server | deb | 22.04 | 3.9.27-0ubuntu0.6 | Not reported | UBUNTU-CVE-2026-67232 | Not reported |
| Ubuntu | rabbitmq-server | deb | 24.04 | 3.12.1-1ubuntu1.7 | Not reported | UBUNTU-CVE-2026-67232 | Not reported |
| Ubuntu | rabbitmq-server | deb | 26.04 | 4.0.5-10ubuntu5.2 | Not reported | UBUNTU-CVE-2026-67232 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [rabbitmq-server]Affected
Details (4)
3.10.8-1.1+deb12u1· all · bookwormAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookwormAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookworm-securityAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookworm-securityAffected
nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12
[Debian 13 (Trixie)]
- [rabbitmq-server]Affected
Details (2)
4.0.5-6+deb13u2· all · trixieAffected
nvd · rabbitmq-server · debian · 13
4.0.5-6+deb13u2· all · trixieAffected
nvd · rabbitmq-server · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-67232]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-67232]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-67232]
- [https://security-tracker.debian.org/tracker/CVE-2026-67232]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-67232.json]
- [https://ubuntu.com/security/notices/USN-8933-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2268.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX] · [Ubuntu Security Notices (USN)]