CVE catalog

CVE-2026-67405

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, Neither the Web-MQTT handler (deps/rabbitmq_web_mqtt/src/rabbit_web_mqtt_handler.erl:104) nor

[CVE catalog]

Severity
High · CVSS 8.1CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Published
Updated
Source
[NVD] · [CVE record]
EPSS
0.11% · Oct 27, 2026

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, Neither the Web-MQTT handler (deps/rabbitmq_web_mqtt/src/rabbit_web_mqtt_handler.erl:104) nor the Web-STOMP handler (deps/rabbitmq_web_stomp/src/rabbit_web_stomp_handler.erl:102) validates the Origin header on the WebSocket upgrade. Under ssl_cert_login=true, the browser presents the client certificate automatically, so an attacker's JavaScript running in the victim's browser can authenticate as the victim. Preconditions include The non-default configuration use_http_auth=true (Web-STOMP) or ssl_cert_login=true (both plugins) must be enabled. The issue is harmless under the default in-band CONNECT credential configuration.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianrabbitmq-serversid4.3.6-1fixed
Debianrabbitmq-serverforky4.3.6-1fixed
Debianrabbitmq-servertrixie4.0.5-6+deb13u2vulnerable
Debianrabbitmq-serverbookworm3.10.8-1.1+deb12u1vulnerable
Debianrabbitmq-serverbookworm-security3.10.8-1.1+deb12u1vulnerable
Cperabbitmq_serverNot reported4.2.6fixed
Ubunturabbitmq-serverpro3.7.8-4ubuntu2vulnerable
Ubunturabbitmq-serverpro3.7.18-1vulnerable
Ubunturabbitmq-serverpro3.8.2-0ubuntu1vulnerable
Ubunturabbitmq-serverpro3.8.2-0ubuntu1.1vulnerable
Ubunturabbitmq-serverpro3.8.2-0ubuntu1.2vulnerable
Ubunturabbitmq-serverpro3.8.2-0ubuntu1.3vulnerable
Ubunturabbitmq-serverpro3.8.2-0ubuntu1.4vulnerable
Ubunturabbitmq-serverpro3.8.2-0ubuntu1.5vulnerable
Ubunturabbitmq-serverpro3.8.3-0ubuntu0.1vulnerable
Ubunturabbitmq-serverpro3.8.3-0ubuntu0.2vulnerable
Ubunturabbitmq-serverpro3.8.3-0ubuntu0.3vulnerable
Ubunturabbitmq-serverpro3.8.3-0ubuntu0.3+esm1vulnerable
Ubunturabbitmq-serverpro3.8.3-0ubuntu0.3+esm2vulnerable
Ubunturabbitmq-server22.043.8.9-3ubuntu1vulnerable
Ubunturabbitmq-server22.043.9.8-1vulnerable
Ubunturabbitmq-server22.043.9.8-2vulnerable
Ubunturabbitmq-server22.043.9.8-3vulnerable
Ubunturabbitmq-server22.043.9.8-5vulnerable
Ubunturabbitmq-server22.043.9.8-6vulnerable
Ubunturabbitmq-server22.043.9.13-1vulnerable
Ubunturabbitmq-server22.043.9.13-1ubuntu0.22.04.1vulnerable
Ubunturabbitmq-server22.043.9.13-1ubuntu0.22.04.2vulnerable
Ubunturabbitmq-server22.043.9.27-0ubuntu0.1vulnerable
Ubunturabbitmq-server22.043.9.27-0ubuntu0.2vulnerable
Ubunturabbitmq-server22.043.9.27-0ubuntu0.5vulnerable
Ubunturabbitmq-server22.043.9.27-0ubuntu0.6vulnerable
Ubunturabbitmq-server24.043.12.1-1vulnerable
Ubunturabbitmq-server24.043.12.1-1ubuntu1vulnerable
Ubunturabbitmq-server24.043.12.1-1ubuntu1.2vulnerable
Ubunturabbitmq-server24.043.12.1-1ubuntu1.4vulnerable
Ubunturabbitmq-server24.043.12.1-1ubuntu1.6vulnerable
Ubunturabbitmq-server24.043.12.1-1ubuntu1.7vulnerable
Ubunturabbitmq-server26.044.0.5-8ubuntu2vulnerable
Ubunturabbitmq-server26.044.0.5-10ubuntu1vulnerable
Ubunturabbitmq-server26.044.0.5-10ubuntu2vulnerable
Ubunturabbitmq-server26.044.0.5-10ubuntu3vulnerable
Ubunturabbitmq-server26.044.0.5-10ubuntu4vulnerable
Ubunturabbitmq-server26.044.0.5-10ubuntu5vulnerable
Ubunturabbitmq-server26.044.0.5-10ubuntu5.1vulnerable
Ubunturabbitmq-server26.044.0.5-10ubuntu5.2vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianrabbitmq-serversourcesid4.3.0-2not yet assignedNot reportedNot reported
Debianrabbitmq-serversourceforky4.3.0-2not yet assignedNot reportedNot reported
Debianrabbitmq-serversourcetrixie(unfixed)not yet assignedNot reportedNot reported
Debianrabbitmq-serversourcebookworm(unfixed)not yet assignedNot reportedNot reported
Cperabbitmq_servercpeNot reported4.2.6Not reportedNVD-CVE-2026-67405Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [rabbitmq-server]Affected
    Details (4)
    • 3.10.8-1.1+deb12u1 · all · bookworm

      Affected

      nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12

    • 3.10.8-1.1+deb12u1 · all · bookworm

      Affected

      nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12

    • 3.10.8-1.1+deb12u1 · all · bookworm-security

      Affected

      nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12

    • 3.10.8-1.1+deb12u1 · all · bookworm-security

      Affected

      nvd · rabbitmq-server · debian · bookworm; nvd · rabbitmq-server · debian · 12

[Debian 13 (Trixie)]

  • [rabbitmq-server]Affected
    Details (2)
    • 4.0.5-6+deb13u2 · all · trixie

      Affected

      nvd · rabbitmq-server · debian · 13

    • 4.0.5-6+deb13u2 · all · trixie

      Affected

      nvd · rabbitmq-server · debian · 13

Observed:

References