
CVE catalog
CVE-2026-67419
RabbitMQ is a messaging and streaming broker. Prior to 4.3.5, an authenticated user who can bind a queue to a topic exchange and publish to it can use consecutive # segments in a binding key to make b
- Severity
- High · CVSS 7.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.37% · Oct 25, 2026
RabbitMQ is a messaging and streaming broker. Prior to 4.3.5, an authenticated user who can bind a queue to a topic exchange and publish to it can use consecutive # segments in a binding key to make both topic matchers revisit the same trie-node and routing-key-suffix states without memoization. The matcher materializes duplicate destinations before deduplication, causing combinatorial CPU work and memory pressure that can disrupt routing for all tenants. This vulnerability is fixed in 4.3.5.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rabbitmq-server | sid | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | forky | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | trixie | 4.0.5-6+deb13u2 | not affected |
| Debian | rabbitmq-server | bookworm | 3.10.8-1.1+deb12u1 | not affected |
| Debian | rabbitmq-server | bookworm-security | 3.10.8-1.1+deb12u1 | not affected |
| Cpe | rabbitmq_server | Not reported | 4.3.5 | fixed |
| Bitnami | rabbitmq | Not reported | 4.3.5 | fixed |
| Ubuntu | rabbitmq-server | pro | 3.7.8-4ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.7.18-1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.3 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.2-0ubuntu1.5 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.2 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3+esm1 | vulnerable |
| Ubuntu | rabbitmq-server | pro | 3.8.3-0ubuntu0.3+esm2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.8.9-3ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-3 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-5 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.8-6 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1ubuntu0.22.04.1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.13-1ubuntu0.22.04.2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.2 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.5 | vulnerable |
| Ubuntu | rabbitmq-server | 22.04 | 3.9.27-0ubuntu0.6 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.6 | vulnerable |
| Ubuntu | rabbitmq-server | 24.04 | 3.12.1-1ubuntu1.7 | vulnerable |
| Ubuntu | rabbitmq-server | 26.10 | 4.0.5-10ubuntu5 | vulnerable |
| Ubuntu | rabbitmq-server | 26.10 | 4.3.2-4ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 26.10 | 4.3.2-4ubuntu3 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-8ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu3 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu4 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5.1 | vulnerable |
| Ubuntu | rabbitmq-server | 26.04 | 4.0.5-10ubuntu5.2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rabbitmq-server | source | sid | 4.3.6-1 | not yet assigned | Not reported | [1149180] |
| Debian | rabbitmq-server | source | forky | 4.3.6-1 | not yet assigned | Not reported | [1149180] |
| Debian | rabbitmq-server | source | trixie | Not affected | unimportant | Not reported | [1149180] |
| Debian | rabbitmq-server | source | bookworm | Not affected | unimportant | Not reported | [1149180] |
| Cpe | rabbitmq_server | cpe | Not reported | 4.3.5 | Not reported | NVD-CVE-2026-67419 | Not reported |
| Bitnami | rabbitmq | Bitnami | Not reported | 4.3.5 | Not reported | BIT-RABBITMQ-2026-67419 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [rabbitmq-server]Not affected
Details (4)
3.10.8-1.1+deb12u1· all · bookwormNot affected
nvd · rabbitmq-server · debian · bookworm
3.10.8-1.1+deb12u1· all · bookwormNot affected
nvd · rabbitmq-server · debian · bookworm
3.10.8-1.1+deb12u1· all · bookworm-securityNot affected
nvd · rabbitmq-server · debian · bookworm
3.10.8-1.1+deb12u1· all · bookworm-securityNot affected
nvd · rabbitmq-server · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-67419]
- [https://osv.dev/vulnerability/BIT-rabbitmq-2026-67419]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-67419]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-67419]
- [https://security-tracker.debian.org/tracker/CVE-2026-67419]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-67419.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2881.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]