
CVE catalog
CVE-2026-67422
pymdown-extensions is a collection of extensions for the Python Markdown library. In versions up to and including 11.0, four inline processors (caret, tilde, betterem, and magiclink) use regular expre
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.61% · Oct 25, 2026
pymdown-extensions is a collection of extensions for the Python Markdown library. In versions up to and including 11.0, four inline processors (caret, tilde, betterem, and magiclink) use regular expressions whose content groups can partition a run of delimiter characters in exponentially many ways, causing catastrophic backtracking. As a result, a single untrusted Markdown line under 50 bytes rendered with markdown.markdown() in each extension's default configuration drives the rendering thread into unbounded CPU usage that grows exponentially with input length, enabling an unauthenticated remote attacker who can submit Markdown to cause denial of service. The exposure is concrete for web applications that render user-supplied Markdown (comments, wikis, issue bodies, live preview), including any app using pymdownx.extra which bundles the vulnerable betterem default, as well as hosted docs/CI systems that build untrusted Markdown. The issue has been fixed in version 11.0.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | pymdown-extensions | sid | 11.0.1-1 | fixed |
| Debian | pymdown-extensions | forky | 11.0.1-1 | fixed |
| Debian | pymdown-extensions | trixie | 10.13-1+deb13u1 | vulnerable |
| Debian | pymdown-extensions | bookworm | 9.5-2 | vulnerable |
| Pip | pymdown-extensions | Not reported | 11.0.1 | fixed |
| Ubuntu | pymdown-extensions | 24.04 | 9.5-2 | vulnerable |
| Ubuntu | pymdown-extensions | 24.04 | 9.5-4 | vulnerable |
| Ubuntu | pymdown-extensions | 24.04 | 9.5-5 | vulnerable |
| Ubuntu | pymdown-extensions | 26.04 | 10.13-3 | vulnerable |
| Ubuntu | pymdown-extensions | 26.04 | 10.13-4 | vulnerable |
| Ubuntu | pymdown-extensions | 26.04 | 10.19.1-3 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | pymdown-extensions | source | sid | 11.0.1-1 | not yet assigned | Not reported | Not reported |
| Debian | pymdown-extensions | source | forky | 11.0.1-1 | not yet assigned | Not reported | Not reported |
| Debian | pymdown-extensions | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | pymdown-extensions | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Pip | pymdown-extensions | pip | Not reported | 11.0.1 | Not reported | Not reported | Not reported |
Notes
[trixie] pymdown-extensions: Minor issue [bookworm] pymdown-extensions: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [python3-pymdownx]Affected
Source package: [pymdown-extensions]
Details (2)
9.5-2· all · bookwormAffected
nvd · pymdown-extensions · debian · bookworm; nvd · pymdown-extensions · debian · 12
9.5-2· all · bookwormAffected
nvd · pymdown-extensions · debian · bookworm; nvd · pymdown-extensions · debian · 12
[Debian 13 (Trixie)]
- [python3-pymdownx]Affected
Source package: [pymdown-extensions]
Details (2)
10.13-1+deb13u1· all · trixieAffected
nvd · pymdown-extensions · debian · 13
10.13-1+deb13u1· all · trixieAffected
nvd · pymdown-extensions · debian · 13
Observed:
References
- [https://github.com/advisories/GHSA-gm37-52c6-37mw]
- [https://github.com/facelessuser/pymdown-extensions/commit/c68498598d7b13011bb4571350b6e3612a4ce44b]
- [https://github.com/facelessuser/pymdown-extensions/security/advisories/GHSA-gm37-52c6-37mw]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-67422]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-67422]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-67422]
- [https://security-tracker.debian.org/tracker/CVE-2026-67422]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-67422.json]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]