
CVE catalog
CVE-2026-67550
re2 provides Node.js bindings for Google's RE2 regular expression engine. Prior to 1.25.2, re2 validates lastIndex against the UTF-8 byte length of a subject but uses it as a UTF-16 code-unit offset i
- Severity
- Medium · CVSS 5.7
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.16% · Oct 27, 2026
re2 provides Node.js bindings for Google's RE2 regular expression engine. Prior to 1.25.2, re2 validates lastIndex against the UTF-8 byte length of a subject but uses it as a UTF-16 code-unit offset in exec, test, match, replace, and split, allowing an attacker-influenced lastIndex on a non-ASCII subject to trigger an out-of-bounds heap read and an uncatchable process crash, with limited heap information disclosure in some cases. This issue is fixed in 1.25.2.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-re2 | sid | 1.27.0+~cs1.8.1-1 | fixed |
| Debian | node-re2 | forky | 1.26.1+~cs1.8.0-1 | fixed |
| Debian | node-re2 | trixie | 1.21.4+~cs2.13.13-2 | vulnerable |
| Debian | node-re2 | bookworm | 1.18.0+~cs2.13.8-1 | vulnerable |
| Npm | re2 | Not reported | 1.25.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-re2 | source | sid | 1.26.1+~cs1.7.0-1 | not yet assigned | Not reported | [1143179] |
| Debian | node-re2 | source | forky | 1.26.1+~cs1.7.0-1 | not yet assigned | Not reported | [1143179] |
| Debian | node-re2 | source | trixie | (unfixed) | not yet assigned | Not reported | [1143179] |
| Debian | node-re2 | source | bookworm | (unfixed) | not yet assigned | Not reported | [1143179] |
| Npm | re2 | npm | Not reported | 1.25.2 | Not reported | Not reported | Not reported |
Notes
[trixie] node-re2: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-re2]Affected
Details (2)
1.18.0+~cs2.13.8-1· amd64 · bookwormAffected
nvd · node-re2 · debian · bookworm; nvd · node-re2 · debian · 12
1.18.0+~cs2.13.8-1· arm64 · bookwormAffected
nvd · node-re2 · debian · bookworm; nvd · node-re2 · debian · 12
[Debian 13 (Trixie)]
Observed:
References
- [https://github.com/advisories/GHSA-ff84-5f28-78qj]
- [https://github.com/uhop/node-re2/commit/56293de4fc0914d7bc35f92e98de25b0d9bb417d]
- [https://github.com/uhop/node-re2/releases/tag/1.25.2]
- [https://github.com/uhop/node-re2/security/advisories/GHSA-ff84-5f28-78qj]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-67550]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-67550]
- [https://security-tracker.debian.org/tracker/CVE-2026-67550]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-67550.json]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]