
CVE catalog
CVE-2026-68939
pyenv-2.8.4-1.1 on GA media
- Severity
- Medium · CVSS 5.3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.17% · Oct 25, 2026
Pyenv provides simple Python version management. Prior to 2.8.0, is_version_safe() in libexec/pyenv-version-file-read accepts shell glob metacharacters in .python-version values, and unquoted PYENV_VERSION expansion in libexec/pyenv-version-name, libexec/pyenv-which, libexec/pyenv-prefix, libexec/pyenv-local, libexec/pyenv-global, libexec/pyenv-version, and libexec/pyenv-versions pathname-expands the value against the current directory, allowing a matching attacker-controlled file to silently select a different installed interpreter or version. This issue is fixed in version 2.8.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | pyenv | 13 | 2.5.4-1 | vulnerable |
| Debian | pyenv | 13 | 2.5.5-1 | vulnerable |
| Debian | pyenv | 13 | 2.5.5-2 | vulnerable |
| Debian | pyenv | 13 | 2.6.27-1 | vulnerable |
| Debian | pyenv | 13 | 2.6.28-1 | vulnerable |
| Debian | pyenv | 13 | 2.6.8-1 | vulnerable |
| Debian | pyenv | 13 | 2.7.1-1 | vulnerable |
| Debian | pyenv | 14 | 2.5.4-1 | vulnerable |
| Debian | pyenv | 14 | 2.5.5-1 | vulnerable |
| Debian | pyenv | 14 | 2.5.5-2 | vulnerable |
| Debian | pyenv | 14 | 2.6.27-1 | vulnerable |
| Debian | pyenv | 14 | 2.6.28-1 | vulnerable |
| Debian | pyenv | 14 | 2.6.8-1 | vulnerable |
| Debian | pyenv | 14 | 2.7.1-1 | vulnerable |
| Opensuse | pyenv | leap 16.0 | 2.4.14-bp160.2.1 | fixed |
| Opensuse | pyenv | tumbleweed | 2.8.4-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Opensuse | pyenv | rpm | leap 16.0 | 2.4.14-bp160.2.1 | Not reported | OPENSUSE-SU-2026:21664-1 | Not reported |
| Opensuse | pyenv | rpm | tumbleweed | 2.8.4-1.1 | Not reported | OPENSUSE-SU-2026:11613-1 | Not reported |
OpenFactory catalog packages
[Debian 13 (Trixie)]
- [pyenv]Affected
Details (2)
2.5.4-1· all · trixieAffected
pypi · pyenv · debian · 13
2.5.4-1· all · trixieAffected
pypi · pyenv · debian · 13
[openSUSE Tumbleweed]
- [pyenv-bash-completion]Unknown
Source package: [pyenv]
Details (1)
2.8.4-1.1· noarch · tumbleweedUnknown · Fixed:
2.8.4-1.1Version impact unknown
pypi · pyenv · opensuse · tumbleweed
- [pyenv-fish-completion]Unknown
Source package: [pyenv]
Details (1)
2.8.4-1.1· noarch · tumbleweedUnknown · Fixed:
2.8.4-1.1Version impact unknown
pypi · pyenv · opensuse · tumbleweed
- [pyenv-zsh-completion]Unknown
Source package: [pyenv]
Details (1)
2.8.4-1.1· noarch · tumbleweedUnknown · Fixed:
2.8.4-1.1Version impact unknown
pypi · pyenv · opensuse · tumbleweed
- [pyenv]Fixed
Source package: [pyenv]
Details (1)
2.8.4-1.1· x86_64 · tumbleweedFixed · Fixed:
2.8.4-1.1pypi · pyenv · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11613-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-68939]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:11613-1]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:21664-1]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [SUSE security advisories and VEX]