CVE catalog

CVE-2026-69152

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alte

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
0.65% · Oct 25, 2026

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alternative intermediate arrays or padded sequences, allowing attacker-controlled input to exhaust memory or block the event loop. The fix for CVE-2026-14257 is bypassed by the vulnerability. This issue is fixed in versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-brace-expansionsid2.1.7+~1.1.2-1not affected
Debiannode-brace-expansionforky2.1.7+~1.1.2-1not affected
Debiannode-brace-expansiontrixie2.0.1+~1.1.0-2not affected
Debiannode-brace-expansionbookworm2.0.1-2not affected
Npmbrace-expansionNot reported5.0.9fixed
Npmbrace-expansionNot reported2.1.4fixed
Npmbrace-expansionNot reported3.0.6fixed
Npmbrace-expansionNot reported5.0.9fixed
Npmbrace-expansionNot reported1.1.18fixed
Npmbrace-expansionNot reported2.1.4fixed
Npmbrace-expansionNot reported3.0.6fixed
Npmbrace-expansionNot reported5.0.9fixed
Cpebrace-expansionNot reported5.0.9fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-brace-expansionsourcesidNot affectedunimportantNot reportedNot reported
Debiannode-brace-expansionsourceforkyNot affectedunimportantNot reportedNot reported
Debiannode-brace-expansionsourcetrixieNot affectedunimportantNot reportedNot reported
Debiannode-brace-expansionsourcebookwormNot affectedunimportantNot reportedNot reported
Npmbrace-expansionnpmNot reported5.0.9Not reportedGHSA-RGW5-RVV9-X895Not reported
Npmbrace-expansionnpmNot reported2.1.4Not reportedNot reportedNot reported
Npmbrace-expansionnpmNot reported3.0.6Not reportedNot reportedNot reported
Npmbrace-expansionnpmNot reported5.0.9Not reportedNot reportedNot reported
Npmbrace-expansionnpmNot reported1.1.18Not reportedNot reportedNot reported
Npmbrace-expansionnpmNot reported2.1.4Not reportedNot reportedNot reported
Npmbrace-expansionnpmNot reported3.0.6Not reportedNot reportedNot reported
Npmbrace-expansionnpmNot reported5.0.9Not reportedNot reportedNot reported
Cpebrace-expansioncpeNot reported5.0.9Not reportedNVD-CVE-2026-69152Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [node-brace-expansion]Not affected
    Details (2)
    • 2.0.1-2 · all · bookworm

      Not affected

      nvd · node-brace-expansion · debian · bookworm

    • 2.0.1-2 · all · bookworm

      Not affected

      nvd · node-brace-expansion · debian · bookworm

Observed:

References