
CVE catalog
CVE-2026-69220
rabbitmq-java-client: CVE-2026-69220
- Severity
- High · CVSS 8.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.73% · Oct 25, 2026
The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.33.1, src/main/java/com/rabbitmq/client/impl/ValueReader.java permits ValueReader.readTable and ValueReader.readArray to call ValueReader.readFieldValue recursively for AMQP table type F and AMQP array type A values without a nesting-depth limit. A malicious AMQP server or network intermediary can send approximately 580 nested table levels in the pre-authentication connection.start frame, fitting within the default 131072-byte frame maximum, to trigger StackOverflowError. The error terminates the client input processing thread and causes denial of service. This issue is fixed in version 5.33.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rabbitmq-java-client | sid | 5.0.0-2 | vulnerable |
| Debian | rabbitmq-java-client | trixie | 5.0.0-1.1 | vulnerable |
| Debian | rabbitmq-java-client | bookworm | 5.0.0-1.1 | vulnerable |
| Maven | com.rabbitmq:amqp-client | Not reported | 5.33.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rabbitmq-java-client | source | sid | (unfixed) | not yet assigned | Not reported | [1144958] |
| Debian | rabbitmq-java-client | source | trixie | (unfixed) | not yet assigned | Not reported | [1144958] |
| Debian | rabbitmq-java-client | source | bookworm | (unfixed) | not yet assigned | Not reported | [1144958] |
| Maven | com.rabbitmq:amqp-client | maven | Not reported | 5.33.1 | Not reported | GHSA-93J5-89VC-PPH4 | Not reported |
Notes
[trixie] rabbitmq-java-client: Minor issue [bookworm] rabbitmq-java-client: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [librabbitmq-client-java]Affected
Source package: [rabbitmq-java-client]
Details (2)
5.0.0-1.1· all · bookwormAffected
dsa · rabbitmq-java-client · debian · bookworm; dsa · rabbitmq-java-client · debian · 12
5.0.0-1.1· all · bookwormAffected
dsa · rabbitmq-java-client · debian · bookworm; dsa · rabbitmq-java-client · debian · 12
[Debian 13 (Trixie)]
- [librabbitmq-client-java]Affected
Source package: [rabbitmq-java-client]
Details (2)
5.0.0-1.1· all · trixieAffected
dsa · rabbitmq-java-client · debian · 13
5.0.0-1.1· all · trixieAffected
dsa · rabbitmq-java-client · debian · 13
Observed:
References
- [https://github.com/advisories/GHSA-93j5-89vc-pph4]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-69220]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-69220]
- [https://security-tracker.debian.org/tracker/CVE-2026-69220]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2921.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]