
CVE catalog
CVE-2026-71436
DEBIAN-CVE-2026-71436
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.58% · Oct 25, 2026
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 10.6.0 until 10.9.8 and 11.16.1, Mermaid XY Charts are vulnerable to an infinite loop denial of service in the setXAxisRangeData function when configuring an X-Axis with invalid parameters. Because each loop iteration appends an element to an array, this generally causes a RangeError to appear after a few seconds, but it may instead cause the page or JavaScript process to crash from memory exhaustion, depending on the environment. This issue is fixed in versions 10.9.8 and 11.16.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-mermaid | 14 | 8.11.0+ds+~cs29.13.22-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.2+ds+~cs30.13.21-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.2+ds+~cs30.13.21-1.1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.3+ds+~cs26.13.21-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.3+ds+~cs26.13.21-2 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.8+~cs10.4.16-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.14.0+ds1+~cs11.4.14-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.14.0+~cs11.4.14-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-2 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-2~bpo10+1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-3 | vulnerable |
| Debian | node-mermaid | 14 | 8.9.1+ds+~cs26.20.25-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.9.3+ds+~cs29.13.19-1 | vulnerable |
| Debian | node-mermaid | 14 | 9.2.2+~2.0.0-1 | vulnerable |
| Debian | node-mermaid | 14 | 9.2.2+~2.0.0-2 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://github.com/mermaid-js/mermaid/commit/630aa7e5dd417e1f56bff2a1ce8df2c5ad08d289]
- [https://github.com/mermaid-js/mermaid/commit/ef60adc837d9d5107af21285f01e83dea309bd0a]
- [https://github.com/mermaid-js/mermaid/pull/8022]
- [https://github.com/mermaid-js/mermaid/releases/tag/mermaid@11.16.1]
- [https://github.com/mermaid-js/mermaid/releases/tag/v10.9.8]
- [https://github.com/mermaid-js/mermaid/security/advisories/GHSA-2v8p-3f2j-5mp7]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-71436]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-71436]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-71436.json]
[FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]