
CVE catalog
CVE-2026-71437
DEBIAN-CVE-2026-71437
- Severity
- Unknown · CVSS 6.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.50% · Oct 25, 2026
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 11.5.0 until 11.16.1, Mermaid Architecture Diagrams are vulnerable to prototype pollution when a diagram defines a group with an id of __proto__. Because the group id is used directly as an object property key without validation, an attacker who can supply diagram text can pollute Object.prototype, potentially affecting the behavior of the embedding application. This issue is fixed in version 11.16.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-mermaid | 14 | 8.11.0+ds+~cs29.13.22-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.2+ds+~cs30.13.21-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.2+ds+~cs30.13.21-1.1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.3+ds+~cs26.13.21-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.3+ds+~cs26.13.21-2 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.8+~cs10.4.16-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.14.0+ds1+~cs11.4.14-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.14.0+~cs11.4.14-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-2 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-2~bpo10+1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-3 | vulnerable |
| Debian | node-mermaid | 14 | 8.9.1+ds+~cs26.20.25-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.9.3+ds+~cs29.13.19-1 | vulnerable |
| Debian | node-mermaid | 14 | 9.2.2+~2.0.0-1 | vulnerable |
| Debian | node-mermaid | 14 | 9.2.2+~2.0.0-2 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://github.com/mermaid-js/mermaid/commit/99af3fc35ef0a9a9c8c6314521344d67523ddccf]
- [https://github.com/mermaid-js/mermaid/pull/8022]
- [https://github.com/mermaid-js/mermaid/releases/tag/mermaid@11.16.1]
- [https://github.com/mermaid-js/mermaid/security/advisories/GHSA-3rrr-jr9j-h3q3]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-71437]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-71437]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-71437.json]
[FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]