
CVE catalog
CVE-2026-71438
DEBIAN-CVE-2026-71438
- Severity
- Medium · CVSS 4
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.35% · Oct 25, 2026
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.8 and 11.16.1, Mermaid's configuration setters (mermaid.initialize, mermaidAPI.setConfig, and mermaidAPI.updateSiteConfig) merge caller-supplied configuration into Mermaid's internal config using the assignWithDepth deep-merge helper, which is vulnerable to prototype pollution. This is only exploitable if an application forwards untrusted data directly into one of these configuration entry points, which is outside their documented usage; diagram-supplied configuration (e.g. %%{init: {}}%% or YAML frontmatter) is not affected. This issue is fixed in versions 10.9.8 and 11.16.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-mermaid | 14 | 8.11.0+ds+~cs29.13.22-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.2+ds+~cs30.13.21-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.2+ds+~cs30.13.21-1.1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.3+ds+~cs26.13.21-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.3+ds+~cs26.13.21-2 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.8+~cs10.4.16-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.14.0+ds1+~cs11.4.14-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.14.0+~cs11.4.14-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-2 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-2~bpo10+1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-3 | vulnerable |
| Debian | node-mermaid | 14 | 8.9.1+ds+~cs26.20.25-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.9.3+ds+~cs29.13.19-1 | vulnerable |
| Debian | node-mermaid | 14 | 9.2.2+~2.0.0-1 | vulnerable |
| Debian | node-mermaid | 14 | 9.2.2+~2.0.0-2 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://github.com/mermaid-js/mermaid/commit/2cd6dcf735533b323507e3e889ffdea870540b43]
- [https://github.com/mermaid-js/mermaid/commit/c34b07a0815842327e70794d69b0c8c5a1e2a956]
- [https://github.com/mermaid-js/mermaid/pull/8022]
- [https://github.com/mermaid-js/mermaid/releases/tag/mermaid%4011.16.1]
- [https://github.com/mermaid-js/mermaid/releases/tag/v10.9.8]
- [https://github.com/mermaid-js/mermaid/security/advisories/GHSA-c4c3-pg64-4m4v]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-71438]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-71438]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-71438.json]
[FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]