
CVE catalog
CVE-2026-73255
DEBIAN-CVE-2026-73255
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.66% · Oct 25, 2026
Mongoose is an embedded web server and network library. Prior to 7.22, an attacker who can control an SSI-enabled file can place directory traversal sequences in an #include file or #include virtual directive. The mg_ssi() function in src/ssi.c concatenates the directive argument into a filesystem path without calling mg_path_is_sane(), allowing an MG_ENABLE_SSI deployment with ssi_pattern configured to disclose files readable by the Mongoose process. This issue is fixed in version 7.22.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | mongoose | 14 | 7.21+ds-1 | vulnerable |
| Debian | mongoose | 14 | 7.21+ds-1~bpo13+1 | vulnerable |
| Debian | mongoose | 14 | 7.21+ds-2 | vulnerable |
| Debian | mongoose | 14 | 7.22+ds-1~bpo13+1 | vulnerable |
| Debian | mongoose | 14 | 7.22+ds-1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | mongoose | deb | 14 | 7.22+ds-1 | Not reported | DEBIAN-CVE-2026-73255 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed: