
CVE catalog
CVE-2026-73256
DEBIAN-CVE-2026-73256
- Severity
- Critical · CVSS 9.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.44% · Oct 25, 2026
Mongoose is an embedded web server and network library. Prior to 7.22, a remote unauthenticated attacker can exploit an HTTP/1.0 reverse-proxy deployment by sending a request with Transfer-Encoding: chunked and conflicting framing. The http_cb() function in src/http.c tests hm.proto.len with an impossible greater-than-eight condition even though mg_http_parse() requires an eight-byte protocol string, so is_http_1_0 is never set. Mongoose consequently processes chunked encoding that an HTTP/1.0 proxy can ignore, enabling request smuggling and unauthorized access or state changes. This issue is fixed in version 7.22.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | mongoose | 14 | 7.21+ds-1 | vulnerable |
| Debian | mongoose | 14 | 7.21+ds-1~bpo13+1 | vulnerable |
| Debian | mongoose | 14 | 7.21+ds-2 | vulnerable |
| Debian | mongoose | 14 | 7.22+ds-1~bpo13+1 | vulnerable |
| Debian | mongoose | 14 | 7.22+ds-1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | mongoose | deb | 14 | 7.22+ds-1 | Not reported | DEBIAN-CVE-2026-73256 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed: