
CVE catalog
CVE-2026-73258
DEBIAN-CVE-2026-73258
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.46% · Oct 27, 2026
Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can place a lone carriage return or line feed in multipart input processed by mg_http_next_multipart() in src/http.c. The loops comparing s[b] and s[b + 1], and s[h2] and s[h2 + 1], use an incorrect AND condition and stop when either character resembles part of a CRLF terminator. This truncates headers, filenames, or boundaries and can cause an application to accept dangerous content after seeing a misleading Content-Type value. This issue is fixed in version 7.22.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | mongoose | 14 | 7.21+ds-1 | vulnerable |
| Debian | mongoose | 14 | 7.21+ds-1~bpo13+1 | vulnerable |
| Debian | mongoose | 14 | 7.21+ds-2 | vulnerable |
| Debian | mongoose | 14 | 7.22+ds-1~bpo13+1 | vulnerable |
| Debian | mongoose | 14 | 7.22+ds-1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | mongoose | deb | 14 | 7.22+ds-1 | Not reported | DEBIAN-CVE-2026-73258 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed: