
CVE catalog
CVE-2026-73416
DEBIAN-CVE-2026-73416
- Severity
- Medium · CVSS 6.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:L - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.66% · Oct 25, 2026
jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.5.0 until 4.5.10 and 4.6.2, in jupyterlab/extensions/manager.py and jupyterlab/extensions/pypi.py, JupyterLab's PyPI extension manager enforces blocked_extensions_uris by comparing requested install names to blocklist entries with custom normalization that is weaker than PyPI package-name canonicalization. An authenticated user can request a PyPI-equivalent spelling such as JupyterLab.Git for a blocklisted package such as jupyterlab-git, and JupyterLab accepts the install request even though pip resolves the variant to the same package. Security impact requires an allowlist or blocklist intended to restrict package installation, the PyPI Extension Manager, and kernels and terminals that are disabled or delegated to remote hosts. The bypass lets an authenticated user install a prohibited extension, defeat integrity restrictions, and affect availability without gaining new read access. This issue is fixed in versions 4.5.10 and 4.6.2.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | jupyterlab | 13 | 4.0.11+ds1+~cs11.25.27-7 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds1+~cs11.25.27-8 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds1+~cs11.25.27-9 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds2+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds2+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds3+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-2 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-4 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds5+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.13+ds1+~2.0.1+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-5 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds1+~cs11.25.27-7 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds1+~cs11.25.27-8 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds1+~cs11.25.27-9 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds2+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds2+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds3+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-2 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-4 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds5+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.13+ds1+~2.0.1+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | jupyterlab | deb | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 | Not reported | DEBIAN-CVE-2026-73416 | Not reported |
OpenFactory catalog packages
[Debian 13 (Trixie)]
- [jupyterlab]Affected
Details (2)
4.0.11+ds1+~cs11.25.27-7· all · trixieAffected
pypi · jupyterlab · debian · 13
4.0.11+ds1+~cs11.25.27-7· all · trixieAffected
pypi · jupyterlab · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11634-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-73416]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-73416.json]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]