
CVE catalog
CVE-2026-73626
DEBIAN-CVE-2026-73626
- Severity
- Low · CVSS 0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.36% · Oct 25, 2026
JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | jupyterlab | 13 | 4.0.11+ds1+~cs11.25.27-7 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds1+~cs11.25.27-8 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds1+~cs11.25.27-9 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds2+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds2+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds3+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-2 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds4+~cs11.25.27-4 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.11+ds5+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.0.13+ds1+~2.0.1+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7 | vulnerable |
| Debian | jupyterlab | 13 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-5 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6 | vulnerable |
| Debian | jupyterlab | 13 | 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds1+~cs11.25.27-7 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds1+~cs11.25.27-8 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds1+~cs11.25.27-9 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds2+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds2+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds3+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-2 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds4+~cs11.25.27-4 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.11+ds5+~cs11.25.27-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.0.13+ds1+~2.0.1+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7 | vulnerable |
| Debian | jupyterlab | 14 | 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1 | vulnerable |
| Debian | jupyterlab | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | jupyterlab | deb | 14 | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 | Not reported | DEBIAN-CVE-2026-73626 | Not reported |
OpenFactory catalog packages
[Debian 13 (Trixie)]
- [jupyterlab]Affected
Details (2)
4.0.11+ds1+~cs11.25.27-7· all · trixieAffected
pypi · jupyterlab · debian · 13
4.0.11+ds1+~cs11.25.27-7· all · trixieAffected
pypi · jupyterlab · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11634-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-73626]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-73626.json]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]