
CVE catalog
CVE-2026-77281
Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.49% · Oct 25, 2026
Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, allowing injected environment or request-variable placeholders to disclose data and, when the file provider is registered, allowing injected file placeholders to disclose readable files. The issue is fixed in version 2.11.4.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | caddy | sid | 2.11.4-1 | fixed |
| Debian | caddy | forky | 2.11.4-1 | fixed |
| Debian | caddy | trixie | 2.6.2-12+deb13u1 | vulnerable |
| Debian | caddy | trixie-security | 2.6.2-12+deb13u1 | vulnerable |
| Debian | caddy | bookworm | 2.6.2-5 | vulnerable |
| Debian | caddy | bookworm-security | 2.6.2-5+deb12u1 | fixed |
| Go | github.com/caddyserver/caddy/v2 | Not reported | 2.11.4 | fixed |
| Ubuntu | caddy | pro | 2.6.2-12 | vulnerable |
| Ubuntu | caddy | pro | 2.6.2-14 | vulnerable |
| Ubuntu | caddy | pro | 2.6.2-14ubuntu0.26.04.1~esm1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | caddy | source | sid | 2.11.4-1 | not yet assigned | Not reported | Not reported |
| Debian | caddy | source | forky | 2.11.4-1 | not yet assigned | Not reported | Not reported |
| Debian | caddy | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | caddy | source | bookworm | 2.6.2-5+deb12u1 | not yet assigned | Not reported | Not reported |
| Go | github.com/caddyserver/caddy/v2 | go | Not reported | 2.11.4 | Not reported | GHSA-J8PX-RMRX-76H9 | Not reported |
Notes
[trixie] caddy: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [caddy]Affected
Details (2)
2.6.2-5· amd64 · bookwormAffected · Fixed:
2.6.2-5+deb12u1nvd · caddy · debian · bookworm; nvd · caddy · debian · 12
2.6.2-5· arm64 · bookwormAffected · Fixed:
2.6.2-5+deb12u1nvd · caddy · debian · bookworm; nvd · caddy · debian · 12
[Debian 13 (Trixie)]
- [caddy]Affected
Details (5)
2.6.2-12+b3· amd64 · trixieAffected
nvd · caddy · debian · 13
2.6.2-12+b3· arm64 · trixieAffected
nvd · caddy · debian · 13
2.11.2-1~bpo13+1· amd64 · trixie-backportsAffected
nvd · caddy · debian · 13
2.6.2-12+deb13u1· amd64 · trixie-securityAffected
nvd · caddy · debian · 13
2.6.2-12+deb13u1· arm64 · trixie-securityAffected
nvd · caddy · debian · 13
Observed:
References
- [https://github.com/advisories/GHSA-j8px-rmrx-76h9]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-77281]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-77281]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-77281]
- [https://security-tracker.debian.org/tracker/CVE-2026-77281]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]