
CVE catalog
CVE-2026-77635
DEBIAN-CVE-2026-77635
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.49% · Oct 25, 2026
CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | cakephp | 16.04 | 2.7.2-1 | vulnerable |
| Ubuntu | cakephp | 16.04 | 2.8.0-1 | vulnerable |
| Ubuntu | cakephp | 20.04 | 2.10.11-2 | vulnerable |
| Ubuntu | cakephp | 22.04 | 2.10.11-2.1 | vulnerable |
| Ubuntu | cakephp | 22.04 | 2.10.24-1 | vulnerable |
| Debian | cakephp | 11 | 2.10.11-2.1 | vulnerable |
| Debian | cakephp | 11 | 2.10.24-1 | vulnerable |
| Debian | cakephp | 11 | 2.10.24-2 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: