CVE catalog

CVE-2026-82253

DEBIAN-CVE-2026-82253

[CVE catalog]

Severity
Medium · CVSS 6.5CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Published
Updated
Source
[NVD] · [CVE record]
EPSS
0.66% · Oct 25, 2026

gitoxide (Rust crates gix <= 0.72.0 and gix-validate <= 0.10.0) contains a path traversal vulnerability. The submodule name validation function in gix-validate only checks the first occurrence of '..' via name.find(b".."), allowing crafted names such as 'a..b/../../../.git/' to bypass the check; additionally this validation is never invoked in production code paths. Combined with a trust inheritance flaw in Submodule::open(), where the parent repository's git_dir_trust (Trust::Full) is cloned and the ownership verification is skipped, an attacker can craft a malicious .gitmodules file so that a victim tool built on gitoxide reads arbitrary git repository configuration (including embedded credentials) with full trust, bypassing safe-directory protections. Fixed in gix 0.82.0 and gix-validate 0.11.1.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianrust-gix130.69.1-1vulnerable
Debianrust-gix130.69.1-2vulnerable
Debianrust-gix130.73.0-1vulnerable
Debianrust-gix130.73.0-2vulnerable
Debianrust-gix130.73.0-3vulnerable
Debianrust-gix130.73.0-4vulnerable
Debianrust-gix130.83.0-1vulnerable
Debianrust-gix130.83.0-2vulnerable
Debianrust-gix130.86.0-1vulnerable
Debianrust-gix130.87.1-1vulnerable
Debianrust-gix140.69.1-1vulnerable
Debianrust-gix140.69.1-2vulnerable
Debianrust-gix140.73.0-1vulnerable
Debianrust-gix140.73.0-2vulnerable
Debianrust-gix140.73.0-3vulnerable
Debianrust-gix140.73.0-4vulnerable
Debianrust-gix140.83.0-1fixed
Debianrust-gix-validate130.10.1-1vulnerable
Debianrust-gix-validate130.11.1-1vulnerable
Debianrust-gix-validate130.11.3-1vulnerable
Debianrust-gix-validate130.11.4-1vulnerable
Debianrust-gix-validate130.9.2-1vulnerable
Debianrust-gix-validate140.10.1-1vulnerable
Debianrust-gix-validate140.9.2-1vulnerable
Debianrust-gix-validate140.11.1-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianrust-gixdeb140.83.0-1Not reportedDEBIAN-CVE-2026-82253Not reported
Debianrust-gix-validatedeb140.11.1-1Not reportedDEBIAN-CVE-2026-82253Not reported

OpenFactory catalog packages

[Debian 13 (Trixie)]

  • [librust-gix-dev]Affected

    Source package: [rust-gix]

    Details (2)
    • 0.69.1-1 · amd64 · trixie

      Affected

      pypi · rust-gix · debian · 13

    • 0.69.1-1 · arm64 · trixie

      Affected

      pypi · rust-gix · debian · 13

  • Source package: [rust-gix-validate]

    Details (2)
    • 0.9.2-1 · amd64 · trixie

      Affected

      pypi · rust-gix-validate · debian · 13

    • 0.9.2-1 · arm64 · trixie

      Affected

      pypi · rust-gix-validate · debian · 13

Observed:

References