
CVE catalog
CVE-2026-83557
DefaultBaseTypeLimitingValidator is the PolymorphicTypeValidator applied automatically whenever @JsonTypeInfo is used without an explicitly configured custom validator. It denies polymorphic resolutio
- Severity
- Medium · CVSS 5.6
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.72% · Oct 25, 2026
DefaultBaseTypeLimitingValidator is the PolymorphicTypeValidator applied automatically whenever @JsonTypeInfo is used without an explicitly configured custom validator. It denies polymorphic resolution only for a fixed set of "unsafe base types", and its isSafeSubType method returns true unconditionally for every base type outside that set. java.lang.Comparable was absent from the list despite being implemented by a very large fraction of JDK and application classes, comparable in breadth to java.io.Serializable, which is on the list for that reason. An application declaring an @JsonTypeInfo-annotated property or class with Comparable as its base type, and no custom PolymorphicTypeValidator, will accept a type identifier for essentially any class implementing Comparable. This yields an attacker-controlled object instantiation primitive; a demonstrated case constructs a java.io.File for an arbitrary attacker-chosen path, which becomes path-traversal-adjacent if the application subsequently calls path-sensitive methods on the value. No class implementing Comparable has been identified that yields code execution through deserialization alone. Global Default Typing via activateDefaultTyping is not affected, because that method structurally requires an explicit PolymorphicTypeValidator argument. This affects com.fasterxml.jackson.core:jackson-databind from 2.11.0 before 2.18.10, from 2.19.0 before 2.21.6, and from 2.22.0 before 2.22.2, and tools.jackson.core:jackson-databind from 3.0.0 before 3.1.6 and from 3.2.0 before 3.2.2. Users should upgrade to 2.18.10, 2.21.6, 2.22.2, 3.1.6, or 3.2.2.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | jackson-databind | sid | 2.22.4-1 | fixed |
| Debian | jackson-databind | forky | 2.18.11-1 | fixed |
| Debian | jackson-databind | trixie | 2.14.0+ds-1+deb13u1 | vulnerable |
| Debian | jackson-databind | trixie-security | 2.14.0+ds-1+deb13u1 | vulnerable |
| Debian | jackson-databind | bookworm | 2.14.0-1+deb12u1 | vulnerable |
| Debian | jackson-databind | bookworm-security | 2.14.0-1+deb12u1 | vulnerable |
| Maven | tools.jackson.core:jackson-databind | Not reported | 3.2.2 | fixed |
| Maven | com.fasterxml.jackson.core:jackson-databind | Not reported | 2.22.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | jackson-databind | source | sid | 2.18.11-1 | not yet assigned | Not reported | [1146640] |
| Debian | jackson-databind | source | forky | 2.18.11-1 | not yet assigned | Not reported | [1146640] |
| Debian | jackson-databind | source | trixie | (unfixed) | not yet assigned | Not reported | [1146640] |
| Debian | jackson-databind | source | bookworm | (unfixed) | not yet assigned | Not reported | [1146640] |
| Maven | tools.jackson.core:jackson-databind | maven | Not reported | 3.2.2 | Not reported | GHSA-GX83-3VF8-GH7J | Not reported |
| Maven | com.fasterxml.jackson.core:jackson-databind | maven | Not reported | 2.22.2 | Not reported | GHSA-GX83-3VF8-GH7J | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libjackson2-databind-java]Affected
Source package: [jackson-databind]
Details (4)
2.14.0-1+deb12u1· all · bookwormAffected
nvd · jackson-databind · debian · bookworm; nvd · jackson-databind · debian · 12
2.14.0-1+deb12u1· all · bookwormAffected
nvd · jackson-databind · debian · bookworm; nvd · jackson-databind · debian · 12
2.14.0-1+deb12u1· all · bookworm-securityAffected
nvd · jackson-databind · debian · bookworm; nvd · jackson-databind · debian · 12
2.14.0-1+deb12u1· all · bookworm-securityAffected
nvd · jackson-databind · debian · bookworm; nvd · jackson-databind · debian · 12
[Debian 13 (Trixie)]
- [libjackson2-databind-java]Affected
Source package: [jackson-databind]
Details (4)
2.14.0+ds-1+deb13u1· all · trixieAffected
nvd · jackson-databind · debian · 13
2.14.0+ds-1+deb13u1· all · trixieAffected
nvd · jackson-databind · debian · 13
2.14.0+ds-1+deb13u1· all · trixie-securityAffected
nvd · jackson-databind · debian · 13
2.14.0+ds-1+deb13u1· all · trixie-securityAffected
nvd · jackson-databind · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11877-1.json]
- [https://github.com/advisories/GHSA-gx83-3vf8-gh7j]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-83557]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-83557]
- [https://security-tracker.debian.org/tracker/CVE-2026-83557]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-83557.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-3147.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]