
CVE catalog
CVE-2026-84890
undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output si
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.41% · Oct 25, 2026
undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-undici | sid | 8.12.2+dfsg+~cs3.2.3-2 | fixed |
| Debian | node-undici | forky | 8.10.2+dfsg+~cs3.2.2-1 | fixed |
| Debian | node-undici | trixie | 7.3.0+dfsg1+~cs24.12.11-1 | vulnerable |
| Debian | node-undici | bookworm | 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4 | vulnerable |
| Debian | node-undici | bookworm-security | 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3 | vulnerable |
| Cpe | undici | Not reported | 8.10.2 | fixed |
| Npm | undici | Not reported | 8.10.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-undici | source | sid | 8.10.2+dfsg+~cs3.2.2-1 | not yet assigned | Not reported | [1146745] |
| Debian | node-undici | source | forky | 8.10.2+dfsg+~cs3.2.2-1 | not yet assigned | Not reported | [1146745] |
| Debian | node-undici | source | trixie | (unfixed) | not yet assigned | Not reported | [1146745] |
| Debian | node-undici | source | bookworm | (unfixed) | not yet assigned | Not reported | [1146745] |
| Cpe | undici | cpe | Not reported | 8.10.2 | Not reported | NVD-CVE-2026-84890 | Not reported |
| Npm | undici | npm | Not reported | 8.10.2 | Not reported | GHSA-3XPG-4RPP-HHHM | Not reported |
Notes
[trixie] node-undici: Minor issue [bookworm] node-undici: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-llhttp]Affected
Source package: [node-undici]
Details (4)
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormAffected
nvd · node-undici · debian · bookworm; nvd · node-undici · debian · 12
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormAffected
nvd · node-undici · debian · bookworm; nvd · node-undici · debian · 12
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityAffected
nvd · node-undici · debian · bookworm; nvd · node-undici · debian · 12
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityAffected
nvd · node-undici · debian · bookworm; nvd · node-undici · debian · 12
- [node-undici]Affected
Details (4)
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormAffected
nvd · node-undici · debian · bookworm; nvd · node-undici · debian · 12
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormAffected
nvd · node-undici · debian · bookworm; nvd · node-undici · debian · 12
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityAffected
nvd · node-undici · debian · bookworm; nvd · node-undici · debian · 12
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityAffected
nvd · node-undici · debian · bookworm; nvd · node-undici · debian · 12
[Debian 13 (Trixie)]
- [libllhttp9.2]Affected
Source package: [node-undici]
Details (2)
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· amd64 · trixieAffected
nvd · node-undici · debian · 13
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· arm64 · trixieAffected
nvd · node-undici · debian · 13
- [libllhttp-dev]Affected
Source package: [node-undici]
Details (2)
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· amd64 · trixieAffected
nvd · node-undici · debian · 13
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· arm64 · trixieAffected
nvd · node-undici · debian · 13
- [node-llhttp]Affected
Source package: [node-undici]
Details (2)
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· all · trixieAffected
nvd · node-undici · debian · 13
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· all · trixieAffected
nvd · node-undici · debian · 13
- [node-undici]Affected
Details (2)
7.3.0+dfsg1+~cs24.12.11-1· all · trixieAffected
nvd · node-undici · debian · 13
7.3.0+dfsg1+~cs24.12.11-1· all · trixieAffected
nvd · node-undici · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_22111-1.json]
- [https://github.com/advisories/GHSA-3xpg-4rpp-hhhm]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-84890]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-84890]
- [https://security-tracker.debian.org/tracker/CVE-2026-84890]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-84890.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-3596.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]