
CVE catalog
CVE-2026-85979
Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a special
- Severity
- High · CVSS 8.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.29% · Oct 25, 2026
Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a specially crafted value for this parameter, which is passed to a shell execution context without sufficient sanitization. Because the resulting commands are executed with root privileges, successful exploitation can lead to full compromise of the affected system. It affects Puppet Enterprise 2023.8.0 through 2023.8.10 and Puppet Enterprise 2025.0.0 through 2025.11.2. This has been resolved in Puppet Enterprise 2023.8.11 and Puppet Enterprise 2025.11.3.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | puppetserver | sid | 8.7.0-7 | not affected |
| Debian | puppetserver | trixie | 8.7.0-5 | not affected |
| Debian | puppetserver | bookworm | 7.9.5-2+deb12u1 | not affected |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | puppetserver | source | sid | Not affected | unimportant | Not reported | Not reported |
| Debian | puppetserver | source | trixie | Not affected | unimportant | Not reported | Not reported |
| Debian | puppetserver | source | bookworm | Not affected | unimportant | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [puppet-master]Not affected
Source package: [puppetserver]
Details (2)
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
- [puppet-master-passenger]Not affected
Source package: [puppetserver]
Details (2)
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
- [puppetserver]Not affected
Details (2)
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
7.9.5-2+deb12u1· all · bookwormNot affected
nvd · puppetserver · debian · bookworm
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-85979]
- [https://security-tracker.debian.org/tracker/CVE-2026-85979]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-3342.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)]