
CVE catalog
CVE-2026-86243
Buffer over-read vulnerability in Apache Tomcat Native…
Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.56% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [
{
"name": "tomcat-native",
"status": "fixed",
"release": "sid",
"version": "2.0.16-1"
},
{
"name": "tomcat-native",
"status": "fixed",
"release": "forky",
"version": "2.0.16-1"
},
{
"name": "tomcat-native",
"status": "vulnerable",
"release": "trixie",
"version": "1.3.1-1"
},
{
"name": "tomcat-native",
"status": "vulnerable",
"release": "bookworm",
"version": "1.2.35-1"
}
],
"fixed_versions": [
{
"bug": null,
"name": "tomcat-native",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "2.0.16-1"
},
{
"bug": null,
"name": "tomcat-native",
"type": "source",
"origin": null,
"release": "forky",
"urgency": "not yet assigned",
"fixed_version": "2.0.16-1"
},
{
"bug": null,
"name": "tomcat-native",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "not yet assigned",
"fixed_version": ""
},
{
"bug": null,
"name": "tomcat-native",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": ""
}
],
"distribution_packages": [
{
"name": "tomcat_native",
"ranges": [
{
"fixed": "2.0.16",
"introduced": "2.0.0",
"last_affected": "",
"start_excluding": ""
}
],
"ecosystem": "cpe",
"fixed_version": "2.0.16",
"provider_record_id": "NVD-CVE-2026-86243"
},
{
"name": "libtcnative-1-0",
"distro": "opensuse",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.3.9-1.1"
}
]
}
],
"release": "tumbleweed",
"versions": [],
"ecosystem": "rpm",
"fixed_version": "1.3.9-1.1",
"provider_record_id": "OPENSUSE-SU-2026:11898-1"
},
{
"name": "libtcnative-2-0",
"distro": "opensuse",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.16-1.1"
}
]
}
],
"release": "tumbleweed",
"versions": [],
"ecosystem": "rpm",
"fixed_version": "2.0.16-1.1",
"provider_record_id": "OPENSUSE-SU-2026:11899-1"
}
]
}Publisher notes
[trixie] tomcat-native: Minor issue [bookworm] tomcat-native: Minor issue
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [libtcnative-1]Unknown
Source package: [tomcat-native]
Details (2)
1.2.35-1· amd64 · bookwormAffected
nvd · tomcat-native · debian · bookworm; nvd · tomcat-native · debian · 12
1.2.35-1· arm64 · bookwormAffected
nvd · tomcat-native · debian · bookworm; nvd · tomcat-native · debian · 12
[Debian 13 (Trixie)]
- [libtcnative-1]Unknown
Source package: [tomcat-native]
Details (2)
1.3.1-1+b1· amd64 · trixieAffected
nvd · tomcat-native · debian · 13
1.3.1-1+b1· arm64 · trixieAffected
nvd · tomcat-native · debian · 13
[openSUSE Tumbleweed]
- [libtcnative-1-0]Unknown
Source package: [libtcnative-1-0]
Details (1)
1.3.8-1.3· x86_64 · tumbleweedAffected · Fixed:
1.3.9-1.1nvd · libtcnative-1-0 · opensuse · tumbleweed
- [libtcnative-1-0-devel]Unknown
Source package: [libtcnative-1-0]
Details (1)
1.3.8-1.3· x86_64 · tumbleweedUnknown · Fixed:
1.3.9-1.1Version impact unknown
nvd · libtcnative-1-0 · opensuse · tumbleweed
- [libtcnative-2-0]Unknown
Source package: [libtcnative-2-0]
Details (1)
2.0.15-1.3· x86_64 · tumbleweedAffected · Fixed:
2.0.16-1.1nvd · libtcnative-2-0 · opensuse · tumbleweed
- [libtcnative-2-0-devel]Unknown
Source package: [libtcnative-2-0]
Details (1)
2.0.15-1.3· x86_64 · tumbleweedUnknown · Fixed:
2.0.16-1.1Version impact unknown
nvd · libtcnative-2-0 · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11898-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-86243]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-86243]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:11898-1]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:11899-1]
- [https://security-tracker.debian.org/tracker/CVE-2026-86243]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-86243.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-3559.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]