
CVE catalog
CVE-2026-86247
Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat
- Severity
- High · CVSS 7.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.20% · Oct 25, 2026
Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | tomcat-native | sid | 2.0.16-1 | fixed |
| Debian | tomcat-native | forky | 2.0.16-1 | fixed |
| Debian | tomcat-native | trixie | 1.3.1-1 | vulnerable |
| Debian | tomcat-native | bookworm | 1.2.35-1 | vulnerable |
| Cpe | tomcat_native | Not reported | 2.0.16 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | tomcat-native | source | sid | 2.0.16-1 | not yet assigned | Not reported | Not reported |
| Debian | tomcat-native | source | forky | 2.0.16-1 | not yet assigned | Not reported | Not reported |
| Debian | tomcat-native | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | tomcat-native | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Cpe | tomcat_native | cpe | Not reported | 2.0.16 | Not reported | NVD-CVE-2026-86247 | Not reported |
Notes
[trixie] tomcat-native: Minor issue [bookworm] tomcat-native: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libtcnative-1]Affected
Source package: [tomcat-native]
Details (2)
1.2.35-1· amd64 · bookwormAffected
nvd · tomcat-native · debian · bookworm; nvd · tomcat-native · debian · 12
1.2.35-1· arm64 · bookwormAffected
nvd · tomcat-native · debian · bookworm; nvd · tomcat-native · debian · 12
[Debian 13 (Trixie)]
- [libtcnative-1]Affected
Source package: [tomcat-native]
Details (2)
1.3.1-1+b1· amd64 · trixieAffected
nvd · tomcat-native · debian · 13
1.3.1-1+b1· arm64 · trixieAffected
nvd · tomcat-native · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11898-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-86247]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-86247]
- [https://security-tracker.debian.org/tracker/CVE-2026-86247]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-86247.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-3559.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]