
CVE catalog
CVE-2026-88056
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.30, 21.2.22, and 22.1.4, Angular Server-Side Rendering
- Severity
- High · CVSS 8.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.54% · Oct 27, 2026
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.30, 21.2.22, and 22.1.4, Angular Server-Side Rendering in @angular/platform-server processes user-controlled resource or request URLs through HttpClient after application code validates them with WHATWG URL parsing. The resolveUrl and parseUrl utilities called String.prototype.trim(), which removed leading Unicode whitespace such as U+00A0 or U+FEFF after the input passed a same-origin check, converting a relative path into a protocol-relative attacker-controlled URL. In affected applications that attach sensitive server-side credentials such as Authorization headers to approved requests, relativeUrlsTransformerInterceptorFn then dispatched the request to the attacker-controlled origin, causing SSRF and credential disclosure. This issue is fixed in versions 20.3.30, 21.2.22, and 22.1.4.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | angular.js | sid | 1.8.3-3 | vulnerable |
| Debian | angular.js | trixie | 1.8.3-3 | vulnerable |
| Debian | angular.js | bookworm | 1.8.3-1+deb12u1 | vulnerable |
| Npm | @angular/platform-server | Not reported | Not reported | unknown |
| Cpe | angular | Not reported | 22.1.4 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | angular.js | source | sid | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | angular.js | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | angular.js | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Cpe | angular | cpe | Not reported | 22.1.4 | Not reported | NVD-CVE-2026-88056 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libjs-angularjs]Affected
Source package: [angular.js]
Details (2)
1.8.3-1+deb12u1· all · bookwormAffected
nvd · angular.js · debian · bookworm; nvd · angular.js · debian · 12
1.8.3-1+deb12u1· all · bookwormAffected
nvd · angular.js · debian · bookworm; nvd · angular.js · debian · 12
[Debian 13 (Trixie)]
- [libjs-angularjs]Affected
Source package: [angular.js]
Details (2)
1.8.3-3· all · trixieAffected
nvd · angular.js · debian · 13
1.8.3-3· all · trixieAffected
nvd · angular.js · debian · 13
Observed:
References
- [https://github.com/advisories/GHSA-f6mr-pjwc-34m4]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-88056]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-88056]
- [https://security-tracker.debian.org/tracker/CVE-2026-88056]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-3318.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]