
CVE catalog
CVE-2026-92287
UBUNTU-CVE-2026-92287
- Severity
- Unknown · CVSS 4.7
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.22% · Oct 27, 2026
Pass-through of unvalidated KMS URLs to KMS clients in Apache C++ Parquet and PyArrow versions 4.0.0 to 25.0.1. This affects users who read Parquet files and configure Parquet decryption properties with a KmsClient implementation. On the reader side, the KMS URL can be application-controlled (specified in the KmsConnectionConfig) or file-controlled. If the user does not leverage application control for this parameter, a file-controlled KMS URL is forwarded to a pluggable KmsClient implementation. If the KMS implementation does not perform host validation and makes use of the provided KMS URL, a KMS token can be sent to a malicious host set by an attacker in the file. Users are recommended to upgrade to version 26.0.0, which disables this behavior by default and requires that users opt-in to it by enabling the read_kms_url flag in the DecryptionConfiguration. Users of affected versions are recommended to either specify the KMS URL in the KmsConnectionConfig when reading files, or ensure any KmsClient implementations validate received KMS URLs. Users that opt-in to file-controlled KMS URLs in version 26.0.0 and later must ensure KmsClients validate KMS URLs.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | apache-arrow | 14 | 22.0.0-1 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.0-1 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-1 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-10 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-11 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-2 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-3 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-4 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-5 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-6 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-7 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-8 | vulnerable |
| Debian | apache-arrow | 14 | 23.0.1-9 | vulnerable |
| Debian | apache-arrow | 14 | 25.0.0-1 | vulnerable |
| Debian | apache-arrow | 14 | 25.0.0-1~exp1 | vulnerable |
| Debian | apache-arrow | 14 | 25.0.0-2 | vulnerable |
| Ubuntu | apache-arrow | 26.10 | 23.0.1-9 | vulnerable |
| Ubuntu | apache-arrow | 26.10 | 23.0.1-11 | vulnerable |
| Ubuntu | apache-arrow | 26.10 | 25.0.0-2build1 | vulnerable |
| Ubuntu | apache-arrow | 26.10 | 25.0.0-2ubuntu1 | vulnerable |
| Ubuntu | apache-arrow | 26.04 | 23.0.1-6 | vulnerable |
| Ubuntu | apache-arrow | 26.04 | 23.0.1-9 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: