
CVE catalog
CVE-2026-96883
UBUNTU-
pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions. To remediate this issue, users should upgrade to version 2.1.2 or later.
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.65% · Oct 27, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "postgresql-9.3",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "pro",
"versions": [
"9.3.1-1",
"9.3.2-1",
"9.3.2-1ubuntu1",
"9.3.2-1ubuntu2",
"9.3.3-1",
"9.3.3-1bzr1",
"9.3.3-1bzr2",
"9.3.4-1",
"9.3.5-0ubuntu0.14.04.1",
"9.3.6-0ubuntu0.14.04",
"9.3.7-0ubuntu0.14.04",
"9.3.8-0ubuntu0.4.04",
"9.3.9-0ubuntu0.14.04",
"9.3.10-0ubuntu0.14.04",
"9.3.11-0ubuntu0.14.04",
"9.3.12-0ubuntu0.14.04",
"9.3.13-0ubuntu0.14.04",
"9.3.14-0ubuntu0.14.04",
"9.3.15-0ubuntu0.14.04",
"9.3.16-0ubuntu0.14.04",
"9.3.17-0ubuntu0.14.04",
"9.3.18-0ubuntu0.14.04.1",
"9.3.19-0ubuntu0.14.04",
"9.3.20-0ubuntu0.14.04",
"9.3.21-0ubuntu0.14.04",
"9.3.22-0ubuntu0.14.04",
"9.3.23-0ubuntu0.14.04",
"9.3.24-0ubuntu0.14.04",
"9.3.24-0ubuntu0.14.04+esm1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2026-96883"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
Observed: